POJ2752 Seek the Name, Seek the Fame【字符串匹配+KMP】

Seek the Name, Seek the Fame

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 21528 Accepted: 11246

Description

The little cat is so famous, that many couples tramp over hill and dale to Byteland, and asked the little cat to give names to their newly-born babies. They seek the name, and at the same time seek the fame. In order to escape from such boring job, the innovative little cat works out an easy but fantastic algorithm:

Step1. Connect the father’s name and the mother’s name, to a new string S.

Step2. Find a proper prefix-suffix string of S (which is not only the prefix, but also the suffix of S).

Example: Father=’ala’, Mother=’la’, we have S = ‘ala’+’la’ = ‘alala’. Potential prefix-suffix strings of S are {‘a’, ‘ala’, ‘alala’}. Given the string S, could you help the little cat to write a program to calculate the length of possible prefix-suffix strings of S? (He might thank you by giving your baby a name:)

Input

The input contains a number of test cases. Each test case occupies a single line that contains the string S described above.

Restrictions: Only lowercase letters may appear in the input. 1 <= Length of S <= 400000.

Output

For each test case, output a single line with integer numbers in increasing order, denoting the possible length of the new baby’s name.

Sample Input

ababcababababcabab
aaaaa

Sample Output

2 4 9 18
1 2 3 4 5

Source

POJ Monthly–2006.01.22,Zeyuan Zhu


问题链接POJ2752 Seek the Name, Seek the Fame

问题简述:(略)

问题分析

  读懂题后知道,这个题要算的是,给定一个字符串s,有哪些长度的s的前缀,同时也是s的后缀。

  首先明确一下前缀和后缀的概念。字符串s的前缀是指,从s的开始字符到s的任意字符为止的子串。字符串s的后缀是指,从s的任意字符到s的最后字符为止的子串。s是既是自身的前缀也是自身的后缀。

  这个问题利用KMP算法的next[]数组来解。首先对于输入的字符串s,计算其next[]数组。然后,根据next[]数组的值进行进一步的计算。

  还需要知道的是next[]数组的定义。对于字符串s的第i个字符s[i],next[i]定义为字符s[i]前面最多有多少个连续的字符和字符串s从初始位置开始的字符匹配。

  从后到前匹配前缀和后缀。如果前缀与后缀匹配,则下一个前缀与后缀匹配的字符串只能在前缀中。

程序说明:(略)

问题链接:(略)

题记:(略)


AC的C语言程序如下:

/* POJ2752 Seek the Name, Seek the Fame */

#include <stdio.h>
#include <string.h>

char s[400000+1];
int next[400000+1];
int result[400000+1];


void setnext(char s[], int next[], int len)
{
    next[0] = -1;

    int i = 0, j = -1;
    while (i < len)
    {
        if (j == -1 || s[i] == s[j]) {
            ++i;
            ++j;
            next[i] = j;
        } else
            j = next[j];
    }
}

int main(void)
{
    int count, t, i;

    while(scanf("%s", s) != EOF) {
        int len = strlen(s);

        // 计算next[]数组值
        setnext(s, next, len);

        // 计算结果:从字符串的尾部开始,下一个只能在与后缀相同的前缀字符串中
        count = 0;
        t = next[len - 1];
        while(t != -1) {
            if(s[t] == s[len - 1])
                result[count++] = t + 1;
            t = next[t];
        }

        // 输出结果
        for(i=count-1; i>=0; i--)
            printf("%d ", result[i]);
        printf("%d\n", len);
    }

    return 0;
}

    原文作者:KMP算法
    原文地址: https://blog.csdn.net/tigerisland45/article/details/51765166
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞