杭电3746  kmp算法求字符串循环节

 话说这道题纠结了两天半,,从周日就开始想的,,就这样一直纠结,纠结,,今天上午终于是ac了,,,,,,题目是让求最少需要增加几个字母,关键是求出字符串的循环节,用kMP算法求循环节,,设字符串长度为len,则循环节长度x=len-next[len-1],由这个公式即可算出来。题目:

Cyclic Nacklace

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 465    Accepted Submission(s): 212

Problem Description CC always becomes very depressed at the end of this month, he has checked his credit card yesterday, without any surprise, there are only 99.9 yuan left. he is too distressed and thinking about how to tide over the last days. Being inspired by the entrepreneurial spirit of “HDU CakeMan”, he wants to sell some little things to make money. Of course, this is not an easy task.

As Christmas is around the corner, Boys are busy in choosing christmas presents to send to their girlfriends. It is believed that chain bracelet is a good choice. However, Things are not always so simple, as is known to everyone, girl’s fond of the colorful decoration to make bracelet appears vivid and lively, meanwhile they want to display their mature side as college students. after CC understands the girls demands, he intends to sell the chain bracelet called CharmBracelet. The CharmBracelet is made up with colorful pearls to show girls’ lively, and the most important thing is that it must be connected by a cyclic chain which means the color of pearls are cyclic connected from the left to right. And the cyclic count must be more than one. If you connect the leftmost pearl and the rightmost pearl of such chain, you can make a CharmBracelet. Just like the pictrue below, this CharmBracelet’s cycle is 9 and its cyclic count is 2:

《杭电3746  kmp算法求字符串循环节》

Now CC has brought in some ordinary bracelet chains, he wants to buy minimum number of pearls to make CharmBracelets so that he can save more money. but when remaking the bracelet, he can only add color pearls to the left end and right end of the chain, that is to say, adding to the middle is forbidden.

CC is satisfied with his ideas and ask you for help.  

Input The first line of the input is a single integer T ( 0 < T <= 100 ) which means the number of test cases.

Each test case contains only one line describe the original ordinary chain to be remade. Each character in the string stands for one pearl and there are 26 kinds of pearls being described by ‘a’ ~’z’ characters. The length of the string Len: ( 3 <= Len <= 100000 ).  

Output For each case, you are required to output the minimum count of pearls added to make a CharmBracelet.  

Sample Input

3 aaa abca abcde  

Sample Output

0 2 5  

ac代码:

#include <iostream>
#include <string.h>
#include <cstdio>
using namespace std;
char str[100010];
int nextt[100010],len;
int get_next(){
  nextt[0]=0;
  for(int i=1;i<len;++i){
    int temp=nextt[i-1];
	while(temp&&str[temp]!=str[i])
		temp=nextt[temp-1];
	if(str[temp]==str[i])
		nextt[i]=temp+1;
	else
		nextt[i]=0;
  }
  int xunhuan=len-nextt[len-1];
  if(len%xunhuan==0){
     if(len/xunhuan==1)
		 return len;
	 else
		 return 0;
  }
  else{
    int num=0;
	while((len+num)%xunhuan){
	  num++;
	}
	return num;
  }
}
int main(){
	
	int kk;
	scanf("%d",&kk);
	while(kk--){
	  scanf("%s",str);
	  len=strlen(str);
	  int x=get_next();
	  printf("%d\n",x);
	}
	return 0;
}
    原文作者:KMP算法
    原文地址: https://blog.csdn.net/wmn_wmn/article/details/6947599
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞