poj2240 Bellman-ford最短路求最大回路

Arbitrage

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 17921 Accepted: 7571

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source   本题是让求是否能够套汇的.(在货币的兑换过程是否可以获利)

#include<iostream>
#include<cstdio>
#include<cstring>
#include<cmath>
#define INF 0x3f3f3f3f

using namespace std;

struct node
{
    double cij;
    int ci,cj;
} edge[10000];
int n,m;
char s[40][100];
char s1[100],s2[100];
double Max[10000];    //double 类型
int path[10000];
int flag=0;
int Bellman(int u0)
{
	flag=0;
    memset(Max,0,sizeof(Max));   //初始化为最小
    Max[u0]=1;
    for(int i=1; i<=n; i++)  //构成环所以要递推n次
    {
        for(int j=0; j<m; j++)
        {
            if(Max[edge[j].ci]*edge[j].cij>Max[edge[j].cj])
                Max[edge[j].cj]=Max[edge[j].ci]*edge[j].cij;
        }
    }
    if(Max[u0]>1.0)
        flag=1;
}
int main()
{
    int Case=1;
    while(~scanf("%d",&n))
    {

        if(n==0)
            break;
        for(int i=0; i<n; i++)
        {
            scanf("%s",s[i]);
        }

        scanf("%d",&m);
        int j,k;
        for(int i=0; i<m; i++)
        {
            double d;
            scanf("%s %lf %s",s1,&d,s2);
            for(j=0; strcmp(s1,s[j]); j++)
                ;
            for(k=0; strcmp(s2,s[k]); k++)
                ;
            edge[i].ci=j;
            edge[i].cj=k;
            edge[i].cij=d;
        }
        for(int i=0; i<n; i++)
        {
            Bellman(i);
            if(flag)
                break;
        }
        if(flag)
            printf("Case %d: Yes\n",Case++);
        else
            printf("Case %d: No\n",Case++);
    }
}

(图论算法理论,实现及应用)

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/became_a_wolf/article/details/47752863
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞