Mac中git的安装问题

mac中的git默认是随着xcode一起安装的,所以一般不必手动安装。但是随着时间的推移,git版本不断升级,自带的git就显得有点老旧了,因此我们需要自己来安装最新的版本。

有两种方式可以安装git

安装完之后,执行git --version,如果你发现依旧是老版本,可以使用下面的方式解决。

以上两种方式,最终都会把执行路径放到/usr/local/bin下面,xcode安装的git会放在/usr/bin下面,而且如果你查看一下PATH

echo $PATH

会发现,/usr/bin是处在/usr/local/bin前面的,所以就导致了旧版本依旧覆盖了新版本。知道了原因之后,解决方式就很简单了,我们只需要把/usr/local/bin放到前面即可。有两种方式

第一种:
编辑/etc/paths(需要管理员权限),调整/usr/local/bin在最前面

第二种:
编辑~/.bashrc或者~/.bash_profile

PATH=/usr/local/bin:$PATH
export PATH

然后执行source ~/.bashrc或者source ~/.bash_profile使改变生效。

此时再次执行git --version应该就会看到新版本了。

    原文作者:chshouyu
    原文地址: https://segmentfault.com/a/1190000000614962
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞

发表评论

电子邮件地址不会被公开。 必填项已用*标注