Wormholes
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input Line 1: A single integer,
F.
F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively:
N,
M, and
W
Lines 2..
M+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: a bidirectional path between
S and
E that requires
T seconds to traverse. Two fields might be connected by more than one path.
Lines
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: A one way path from
S to
E that also moves the traveler back
T seconds. Output Lines 1..
F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes). Sample Input
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
Sample Output
NO YES
Hint For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题目大意:
John有n个农场,m条路径,w个虫洞。现在他想进行一个奇妙的旅行,使他能通过虫洞回到以前。问他能否实现。
一道Ballman—Ford模板题,判负环。
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
using namespace std;
#define inf 0x3f3f3f
#define V 505
#define N 5205
struct node
{
int u, v, t;
}e[N];
int dis[V];
int k,n;
int B_Ford(int s)
{
for(int i=1;i<=n;i++) //初始化
dis[i]=inf;
dis[s]=0; //起点为0
for(int i=1;i<n;i++)
{
int flag=1;
for(int j=0;j<k;j++)
if(dis[e[j].v]>dis[e[j].u]+e[j].t)
{
dis[e[j].v]=dis[e[j].u]+e[j].t;
flag=0;
}
if(flag) return 0; //如果不能松弛了,直接判断没有负环
}
for(int i=0;i<k;i++)
if(dis[e[i].v]>dis[e[i].u]+e[i].t)
return 1; //如果还能松弛则存在负环
return 0;
}
int main()
{
int T, m, t, u, v, time;
scanf("%d", &T);
while(T--)
{
scanf("%d%d%d", &n, &m, &t);
k = 0;
for(int i=0; i<m; i++)
{
scanf("%d%d%d", &u, &v, &time); //路径为双向
e[k].u = u;
e[k].v = v;
e[k++].t = time;
e[k].u = v;
e[k].v = u;
e[k++].t = time;
}
for(int i=0; i<t; i++)
{
scanf("%d%d%d", &u, &v, &time); //虫洞为单向路径
e[k].u = u;
e[k].v = v;
e[k++].t = -time;
}
if(B_Ford(1))
printf("YES\n");
else
printf("NO\n");
}
return 0;
}