POJ1860(Currency Exchange)(Bellman-Ford)

Currency Exchange

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 24166 Accepted: 8781

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR. 

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real R
AB, C
AB, R
BA and C
BA – exchange rates and commissions when exchanging A to B and B to A respectively. 

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10
-2<=rate<=10
2, 0<=commission<=10
2

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10
4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
刚学习Bellman-Ford算法,还是不能够灵活运用:
参考网上代码感觉很受益:  详细题意及题解
#include<iostream>
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int n;  //货币种类 
int m;  //兑换点数量 
int s;  //初始持第s种货币 
double r; //初始本金 
int ans;  //总边数 
double dis[1010];
struct Edge
{
	int v,u;
	double rate,s;
}edge[1010];
bool bellman()
{
	memset(dis,0,sizeof(dis));  
	dis[s]=r;
	for(int i=0;i<n;i++)
	{
		bool flag=false;
		for(int j=0;j<ans;j++)
		{
			if(dis[edge[j].u]<(dis[edge[j].v]-edge[j].s)*edge[j].rate)
			{
				dis[edge[j].u]=(dis[edge[j].v]-edge[j].s)*edge[j].rate;
				flag=true;
			}
		}
		if(!flag)
		return false; 
	}
	for(int i=0;i<ans;i++)
		if(dis[edge[i].u]<(dis[edge[i].v]-edge[i].s)*edge[i].rate)
		   return true;
	return false;
}
int main()
{
	int a,b;
	double v,t,v1,t1;
	while(cin>>n>>m>>s>>r)
	{
		ans=0;
		for(int i=0;i<m;i++)
		{
			cin>>a>>b>>v>>t>>v1>>t1;
			edge[ans].v=a;
			edge[ans].u=b;
			edge[ans].rate=v;
			edge[ans++].s=t;
			edge[ans].v=b;
			edge[ans].u=a;
			edge[ans].rate=v1;
			edge[ans++].s=t1;
		}
		if(bellman())
		cout<<"YES"<<endl;
		else
		cout<<"NO"<<endl;
	}
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/hdd871532887/article/details/50529158
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞