Wormholes POJ - 3259 Bellman_Ford 算法

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 53484 Accepted: 19924

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

USACO 2006 December Gold

[Submit]   [Go Back]   [Status]   [Discuss]


Link: http://poj.org/problem?id=3259


题意给出多个farms,及farm之间的路径长度(双向),利用虫洞进行时光旅行(即路径为负),问是否存在负环。


Bell_Ford算法:

bool Bell_Ford(int s){  //s为起始地点

    memset(dis,INF,sizeof(dis));
    bool flag;
    dis[s]=0;
    for(int j=1;j<=nodeNum-1;j++)
    {
        bool flag=false;
        for(int i=1;i<=edgeNum;i++){
            if(dis[e[i].from]+e[i].cost<dis[e[i].to]){
                dis[e[i].to]=dis[e[i].from]+e[i].cost;
                flag=true;
            }
        }

        if(!flag) break;

    }

判断是否存在负环,存在返回真:

for(int i=1;i<=edgeNum;i++)
        if(dis[e[i].from]+e[i].cost<dis[e[i].to])
            return true;
    return false;

ac代码:

#include<cstdio>
#include<cstring>
using namespace std;
const int INF=0x3f3f3f3f;
const int maxn=10000;

int nodeNum,edgeNum;
struct edge{
    int from,to,cost;
}e[maxn];
int dis[maxn];

bool Bell_Ford(){

    memset(dis,INF,sizeof(dis));
    bool flag;
    dis[1]=0;
    for(int j=1;j<=nodeNum-1;j++)
    {
        bool flag=false;
        for(int i=1;i<=edgeNum;i++){
            if(dis[e[i].from]+e[i].cost<dis[e[i].to]){
                dis[e[i].to]=dis[e[i].from]+e[i].cost;
                flag=true;
            }
        }

        if(!flag) break;

    }
    //for(int i=1;i<=nodeNum;i++) printf("%d\n",dis[i]);
    for(int i=1;i<=edgeNum;i++)
        if(dis[e[i].from]+e[i].cost<dis[e[i].to])
            return true;
    return false;

}



int main(){
    int t;
    scanf("%d",&t);
    while(t--){
        int n,m,w;
        scanf("%d%d%d",&n,&m,&w);
        nodeNum=n;
        edgeNum=m*2+w;
        int f1,f2,cost;
        int cnt=1;
        for(int i=0;i<m;i++){
            scanf("%d%d%d",&f1,&f2,&cost);
            e[cnt].from=f1;
            e[cnt].to=f2;
            e[cnt].cost=cost;
            cnt++;
            e[cnt].from=f2;
            e[cnt].to=f1;
            e[cnt].cost=cost;
            cnt++;
        }
        for(int i=0;i<w;i++){
            scanf("%d%d%d",&f1,&f2,&cost);
            //cost=cost*(-1);
            e[cnt].from=f1;
            e[cnt].to=f2;
            e[cnt].cost=(-cost);
            cnt++;
        }

        if(Bell_Ford()) printf("YES\n");
        else printf("NO\n");
    }
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/jayacm/article/details/76228437
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞