POJ - 1860 Currency Exchange(Bellman-Ford、弗洛伊德)

                                      Currency Exchange

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA – exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

题意描述:

有n种货币m个兑换点,nick手上有s类的货币共v元,下面m行a,b,c,d,e,f;a类货币换成b类货币汇率是c佣金是d,b类货币换成a类货币汇率是e佣金是f。Nick通过一些操作是他的钱数增多,他能否实现(判断正权回路)

解题思路:

判断正权回路,与判断负权回路累死,可以用Bellman-Ford算法和弗洛伊德求出;

用Bellman-Ford与判断负权回路一样只不过判断负权回路dis数组初始化最大,判断正权回路只要初始化最小就好了。用弗洛伊德算法是看了网上别人写的题解,用了两遍弗洛伊德,将第一遍弗洛伊德运算过得各个货币的值与运算两次弗洛伊德的值进行比较要是变大了说明就形成了正权回路。

Bellman-Ford:

#include<stdio.h>
#include<string.h>
double dis[110];
int main()
{
	int n,m,s;
	int a[110],b[110];
	double c[110],d[110],e[110],f[110],v;
	int i,j,k,flag;
	while(scanf("%d%d%d%lf",&n,&m,&s,&v)!=EOF)
	{
		memset(dis,0,sizeof(dis));//判断正权回路dis数组初始化最小 
		dis[s]=v;
		for(i=1;i<=m;i++)//存入各个兑换点的信息 
		{
			scanf("%d%d%lf%lf%lf%lf",&a[i],&b[i],&c[i],&d[i],&e[i],&f[i]);
		}
		
		for(j=1;j<n;j++)
		{
			k=0;
			for(i=1;i<=m;i++)//松弛各边 
			{
				if((dis[a[i]]-d[i])*c[i]>dis[b[i]])
				{
					dis[b[i]]=(dis[a[i]]-d[i])*c[i];
					k=1;
				}
				if((dis[b[i]]-f[i])*e[i]>dis[a[i]])
				{
					dis[a[i]]=(dis[b[i]]-f[i])*e[i];
					k=1;
				}
			}
			if(k==0)
				break;	
		}
		flag=0;
		for(i=1;i<=m;i++)//判断是否含有正权回路 
		{
			if((dis[a[i]]-d[i])*c[i]>dis[b[i]])
			{
				flag=1;
				break;
			}
			if((dis[b[i]]-f[i])*e[i]>dis[a[i]])
			{
				flag=1;
				break;
			}
		}
		if(flag==1)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}

弗洛伊德:

#include<stdio.h>
#include<string.h>
double p[110],q[110],map1[110][110],map2[110][110];
int main()
{
	int n,m,s;
	int a,b;
	double c,d,e,f,v;
	int i,j,k,flag,qq;
	while(scanf("%d%d%d%lf",&n,&m,&s,&v)!=EOF)
	{
		memset(p,0,sizeof(p));
		memset(q,0,sizeof(q));
		memset(map1,0,sizeof(map1));
		memset(map2,0,sizeof(map2));
		q[s]=v;
		//map1存储货币间的汇率,map2存储货币间的佣金 
		for(i=1;i<=m;i++)
		{
			scanf("%d%d%lf%lf%lf%lf",&a,&b,&c,&d,&e,&f);
			map1[a][b]=c;
			map2[a][b]=d;
			map1[b][a]=e;
			map2[b][a]=f;
		}
		//第一遍弗洛伊德,进行各个货币值更新 
		for(k=1;k<=n;k++)
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
					if(((q[i]-map2[i][j])*map1[i][j])>q[j])
						q[j]=(q[i]-map2[i][j])*map1[i][j];
		//第一遍后的值赋给数组p 
		for(i=1;i<=n;i++)
			p[i]=q[i];
		//第二遍弗洛伊德 
		for(k=1;k<=n;k++)
			for(i=1;i<=n;i++)
				for(j=1;j<=n;j++)
					if(((q[i]-map2[i][j])*map1[i][j])>q[j])
						q[j]=(q[i]-map2[i][j])*map1[i][j];
		//判断又经过一遍货币值是否又变大了,又变大了说明形成了正权回路 
		flag=0;
		for(i=1;i<=n;i++)
			if(q[i]>p[i])
			{
				flag=1;
				break;
			}
		if(flag==1)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
} 

 

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/kongsanjin/article/details/81257028
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞