poj 1860 Currency Exchange Bellman-Ford 求正环

题目链接:点击打开链接

Currency Exchange

Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 33885 Accepted: 13008

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR. 

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real R
AB, C
AB, R
BA and C
BA – exchange rates and commissions when exchanging A to B and B to A respectively. 

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10
-2<=rate<=10
2, 0<=commission<=10
2

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10
4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion

题意:话说看了半天也没读懂,最后还是搜了题解,看了手动翻译的题解顿时明白了。手动翻译如下:

我们的城市有几个货币兑换点。让我们假设每一个点都只能兑换专门的两种货币。可以有几个点,专门从事相同货币兑换。每个点都有自己的汇率,外汇汇率的A到B是B的数量你1A。同时各交换点有一些佣金,你要为你的交换操作的总和。在来源货币中总是收取佣金。

例如,如果你想换100美元到俄罗斯卢布兑换点,那里的汇率是29.75,而佣金是0.39,你会得到(100 – 0.39)×29.75=2963.3975卢布。

你肯定知道在我们的城市里你可以处理不同的货币。让每一种货币都用唯一的一个小于N的整数表示。然后每个交换点,可以用6个整数表描述:整数a和b表示两种货币,a到b的汇率,a到b的佣金,b到a的汇率,b到a的佣金。

nick有一些钱在货币S,他希望能通过一些操作(在不同的兑换点兑换),增加他的资本。当然,他想在最后手中的钱仍然是S。帮他解答这个难题,看他能不能完成这个愿望。

输入数据:

第一行四个数,N,表示货币的总数;M,兑换点的数目;S,nick手上的钱的类型;V,nick手上的钱的数目;1<=S<=N<=100, 1<=M<=100, V 是一个实数 0<=V<=103

接下来M行,每行六个数,整数a和b表示两种货币,a到b的汇率,a到b的佣金,b到a的汇率,b到a的佣金(0<=佣金<=102,10-2<=汇率<=102

题解:Bellman-Ford的变型,改变一下松弛操作的条件,求正环,有一个优化,就是如果在一次循环中没有符合条件的就直接返回输出NO,还有就是如果存在一个正环就直接返回输出YES,初始化源点的dis[s]=v,而到其他点的值都为0,那么如果源点到其他点的距离在增加说明存在正环。

AC代码:

#include <cstdio>
#include <iostream>
#include <cstring>
#include <algorithm>
#include <queue>
#include <vector>

using namespace std;

typedef pair <int,int> P;
vector <int> E[110];
int n,m,s;
double v;
double cost[110][110];
double rate[110][110];
double dis[110];

bool Bellman_Ford()
{
    memset(dis,0,sizeof(dis));
    dis[s]=v;
    for(int i=1;i<n;i++)
    {
        bool flag=false;
        for(int j=1;j<=n;j++)
        {
            for(int k=0;k<E[j].size();k++)
            {
                int u=j,to=E[j][k];
                if(dis[to]<(dis[u]-cost[u][to])*rate[u][to])
                {
                    dis[to]=(dis[u]-cost[u][to])*rate[u][to];
                    flag=true;
                }
            }
        }
        if(flag==false) return false;
    }
    for(int i=1;i<=n;i++)
    {
        for(int j=0;j<E[i].size();j++)
        {
            int u=i,to=E[i][j];
            if(dis[to]<(dis[u]-cost[u][to])*rate[u][to])
                return true;
        }
    }
    return false;
}

int main()
{
    scanf("%d%d%d%lf",&n,&m,&s,&v);
    int u,to;
    double rab,cab,rba,cba;
    for(int i=1;i<=m;i++)
    {
        scanf("%d%d%lf%lf%lf%lf",&u,&to,&rab,&cab,&rba,&cba);
        E[u].push_back(to);
        E[to].push_back(u);
        rate[u][to]=rab; rate[to][u]=rba;
        cost[u][to]=cab; cost[to][u]=cba;
    }
    if(Bellman_Ford()) puts("YES");
    else puts("NO");
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/Lakersilk/article/details/79573943
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞