1poj1860(bellman_ford)

http://poj.org/problem?id=1860

Currency Exchange

Time Limit: 1000MSMemory Limit: 30000K
Total Submissions: 13313Accepted: 4572

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR.

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real R
AB, C
AB, R
BA and C
BA – exchange rates and commissions when exchanging A to B and B to A respectively.

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10
3.

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10
-2<=rate<=10
2, 0<=commission<=10
2.

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10
4.

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES

Source

Northeastern Europe 2001, Northern Subregion 题意:
http://blog.csdn.net/lyy289065406/article/details/6645778 代码: #include<iostream>

using namespace std;

int n;     //货币种数(点的 个数)

int m;     //兑换点数量(边的条数)

int s;     //持有第s种货币

double v;  //持有的s货币的本金

int all;  //边总数

double dis[101];  //s到各点的权值

struct points

{

 int a;      //货币a

 int b;      //货币b

 double r;   //rate比率

 double c;   //手续费

}exc[202];

bool bellman(void)

{

 memset(dis,0,sizeof(dis));      //这里与bellman的目的刚好相反。初始化为源点到各点距离无穷小

 dis[s]=v;                       //即bellman本用于找负环,求最小路径,本题是利用同样的思想找正环,求最大路径,给自身的(环)权值为v

 //松弛

 bool flag;

 for(int i=1;i<=n-1;i++)

 {

  flag=false;

  for(int j=0;j<all;j++)

   if(dis[exc[j].b] < (dis[exc[j].a] – exc[j].c) * exc[j].r)         //寻找最长路径

   {                                                                 //进行比较的是”某点到自身的权值”和”某点到另一点的权值”

    dis[exc[j].b] = (dis[exc[j].a] – exc[j].c) * exc[j].r;

    flag=true;

   }

  if(!flag)

   break;

 }    for(int k=0;k<all;k++)                                         

  if(dis[exc[k].b] < (dis[exc[k].a] – exc[k].c) * exc[k].r)           //正环能够无限松弛

   return true;  return false;

} int main()

{

 int a,b;

 double rab,cab,rba,cba;   //临时变量

 while(cin>>n>>m>>s>>v)

 {

  all=0;    //注意初始化,边的条数

  for(int i=0;i<m;i++)//构建邻接矩阵

  {

   cin>>a>>b>>rab>>cab>>rba>>cba;

   exc[all].a=a;//货币a

   exc[all].b=b;

   exc[all].r=rab;

   exc[all++].c=cab;

   exc[all].a=b;

   exc[all].b=a;

   exc[all].r=rba;

   exc[all++].c=cba;

  }

          if(bellman())

      cout<<“YES”<<endl;

     else

      cout<<“NO”<<endl;

 }

 return 0;

}     2012.9.4这题和poj3259差不多 //============================================================================

// Name        : poj1860.cpp

// Author      :

// Version     :

// Copyright   : Your copyright notice

// Description : Hello World in C++, Ansi-style

//============================================================================ #include <iostream>

#include<cstdio>

#include<cstring>

using namespace std;

#define maxn 10000

struct

{

 int a;

 int b;

 double r;

 double c;

}edge[maxn];

double dis[maxn];

int edge_num,point_num;

int n,m,s;

double v;

int bellman_ford()

{

 int i,j;

 memset(dis,0,sizeof(dis));

 //for(i=1;i<=point_num;i++)

 //{

 // dis[i]=0;

 //}

 dis[s]=v;

 for(i=1;i<=point_num-1;i++)

 {

  for(j=1;j<=edge_num;j++)

  {

   if(dis[edge[j].b]<(dis[edge[j].a]-edge[j].c)*edge[j].r)

    dis[edge[j].b]=(dis[edge[j].a]-edge[j].c)*edge[j].r;

  }

 }

 for(i=1;i<=edge_num;i++)

 {

  if(dis[edge[i].b]<(dis[edge[i].a]-edge[i].c)*edge[i].r)

   return 1;

 }

 return 0;

}

int main()

{

 while(scanf(“%d%d%d%lf”,&n,&m,&s,&v)!=EOF)

 {

  int a,b;

  double rab,cab,rba,cba;

  int i;

  int k=0;

  for(i=1;i<=m;i++)

  {

   scanf(“%d%d%lf%lf%lf%lf”,&a,&b,&rab,&cab,&rba,&cba);

   k++;

   edge[k].a=a;

   edge[k].b=b;

   edge[k].r=rab;

   edge[k].c=cab;

   k++;

   edge[k].a=b;

   edge[k].b=a;

   edge[k].r=rba;

   edge[k].c=cba;

  }

  edge_num=k;

  point_num=n;

  if(bellman_ford())

  {

   printf(“YES\n”);

  }

  else

   printf(“NO\n”);

 }

 return 0;

}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/lanjiangzhou/article/details/8993066
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞