1poj2240(bellman_ford||floyd)

http://poj.org/problem?id=2240

Arbitrage

Time Limit: 1000MSMemory Limit: 65536K
Total Submissions: 11173Accepted: 4704

Description

Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.

Input

The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.

Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.

Output

For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.

Sample Input

3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0

Sample Output

Case 1: Yes
Case 2: No

Source

Ulm Local 1996 题意:任意一种货币经过交换后再换回到自己能不能最终得到比原先自己多的钱。 还是bellman_ford()… 这题的数据处理过程值得学习。。。 #include<cstdio>

#include<iostream>

#include<cstring>

using namespace std;

#define maxn 1010

char moneyname[40][40];

struct Edge

{

    int u;

    int v;

    double w;

}edge[maxn];

double dis[maxn];

int n,m;

int bellman_ford()

{

    for(int i=1;i<=n;i++)

    {

        dis[i]=0;

    }

    dis[1]=1;

    for(int i=1;i<=n-1;i++)

    {

        for(int j=1;j<=m;j++)

        {

            if(dis[edge[j].v]<dis[edge[j].u]*edge[j].w)

            {

                dis[edge[j].v]=dis[edge[j].u]*edge[j].w;

            }

        }

    }

    for(int i=1;i<=m;i++)

    {

        if(dis[edge[i].v]<dis[edge[i].u]*edge[i].w)

        {

            return 1;

        }

    }

    return 0;

}

int main()

{

    int count=1;

    while(scanf(“%d”,&n)!=EOF)

    {

        if(n==0)

        break;

        for(int i=1;i<=n;i++)

        {

            scanf(“%s”,moneyname[i]);

        }

        char first[40],last[40];

        double rate;

        int f,l;

        scanf(“%d”,&m);

        for(int i=1;i<=m;i++)

        {

      

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/lanjiangzhou/article/details/8993261
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞