uva 558 Wormholes (Bellman-Ford算法判断负环)

uva 558 Wormholes

In the year 2163, wormholes were discovered. A wormhole is a subspace tunnel through space and time connecting two star systems. Wormholes have a few peculiar properties:

Wormholes are one-way only.

The time it takes to travel through a wormhole is negligible.

A wormhole has two end points, each situated in a star system.

A star system may have more than one wormhole end point within its boundaries.

For some unknown reason, starting from our solar system, it is always possible to end up in any star system by following a sequence of wormholes (maybe Earth is the centre of the universe).

Between any pair of star systems, there is at most one wormhole in either direction.

There are no wormholes with both end points in the same star system. 

All wormholes have a constant time difference between their end points. For example, a specific wormhole may cause the person travelling through it to end up 15 years in the future. Another wormhole may cause the person to end up 42 years in the past.

A brilliant physicist, living on earth, wants to use wormholes to study the Big Bang. Since warp drive has not been invented yet, it is not possible for her to travel from one star system to another one directly. This can be done using wormholes, of course.

The scientist wants to reach a cycle of wormholes somewhere in the universe that causes her to end up in the past. By travelling along this cycle a lot of times, the scientist is able to go back as far in time as necessary to reach the beginning of the universe and see the Big Bang with her own eyes. Write a program to find out whether such a cycle exists.

Input
The input file starts with a line containing the number of cases c to be analysed. Each case starts with a line with two numbers n and m . These indicate the number of star systems ( 1n1000 ) and the number of wormholes ( 0m2000 ) . The star systems are numbered from 0 (our solar system) through n-1 . For each wormhole a line containing three integer numbers x, y and t is given. These numbers indicate that this wormhole allows someone to travel from the star system numbered x to the star system numbered y, thereby ending up t ( 1000t1000 ) years in the future.

Output
The output consists of c lines, one line for each case, containing the word possible if it is indeed possible to go back in time indefinitely, or not possible if this is not possible with the given set of star systems and wormholes.

Sample Input

2
3 3
0 1 1000
1 2 15
2 1 -42
4 4
0 1 10
1 2 20
2 3 30
3 0 -60

Sample Output

possible
not possible

题目大意:n个点,m条边,边给出的信息为:两个端点编号,以及权值,权值可为负数。判断图中是否存在负环。

解题思路:Bellman-Ford算法。

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <cstdlib>
using namespace std;
typedef long long ll;
#define N 2005
const int INF = 0x3f3f3f;
int n, m, flag;
int x[N], y[N], v[N], d[N]; 
void BF() {
    flag = 0;
    for (int i = 0; i < n; i++) d[i] = INF; 
    d[0] = 0;
    int a, b;
    for (int i = 0; i < n - 1; i++) { //迭代n - 1次
        for (int j = 0; j < m; j++) { //检查每条边
            a = x[j], b = y[j];
            if (d[a] < INF) {
                d[b] = min(d[a] + v[j], d[b]); //松弛
            }
        }
    }
    for (int i = 0; i < m; i++) { //若n - 1次更新后,还能更新,则有负环
        a = x[i], b = y[i];
        if (d[b] > d[a] + v[i]) {
            flag = 1;
            return;
        }
    }
}
int main() {
    int T;
    scanf("%d", &T);
    while (T--) {
        scanf("%d %d", &n, &m); 
        for (int i = 0; i < m; i++) {
            scanf("%d %d %d", &x[i], &y[i], &v[i]);
        }
        BF();
        if (flag) printf("possible\n");
        else printf("not possible\n");
    }
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/llx523113241/article/details/46850955
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞