POJ 3259 Wormholes 【bellman-ford】

Language: Default Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 38800 Accepted: 14256

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,  FF farm descriptions follow. 
Line 1 of each farm: Three space-separated integers respectively:  NM, and  W 
Lines 2.. M+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: a bidirectional path between  S and  E that requires  T seconds to traverse. Two fields might be connected by more than one path. 
Lines  M+2.. M+ W+1 of each farm: Three space-separated numbers ( SET) that describe, respectively: A one way path from  S to  E that also moves the traveler back  T seconds.

Output

Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

Source

#include<stdio.h>
int k,n,m,s;
struct node
{
    int x,y,z;
} path[5050];
int dir[505];
int v=1000000;
void fz(int x,int y,int z)
{
    path[k].x=x;
    path[k].y=y;
    path[k].z=z;
    k++;
}
bool Bellman()
{
    int i,j;
    for(i=1; i<=n; i++)
        dir[i]=v;
    dir[1]=0;
    for(i=1; i<=n; i++)
    {
        for(j=1; j<k; j++)
        {
            if(dir[path[j].y]>(dir[path[j].x]+path[j].z))
            {
                dir[path[j].y]=dir[path[j].x]+path[j].z;
            }
        }
    }
    for(j=1; j<k; j++)
    {
        if(dir[path[j].y]>(dir[path[j].x]+path[j].z))
        {
            return true;
        }
    }
    return false;
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int x,y,z,i,j;
        k=1;
        scanf("%d%d%d",&n,&m,&s);
        for(i=0; i<m; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            fz(x,y,z);
            fz(y,x,z);

        }
        for(i=0; i<s; i++)
        {
            scanf("%d%d%d",&x,&y,&z);
            fz(y,x,-z);
        }

        if(Bellman())
            printf("YES\n");
        else
            printf("NO\n");
    }
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/nuanxin_520/article/details/50379439
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞