Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题目的大意是有F个农场(F组输入数据),每个农场有N个牧场,M条双向路径,W个虫洞,虫洞是单向的,可以实现时间旅行,返回到以前某个时间。问从某个牧场出发,经过若干路径和虫洞,能不能在自己没有离开出发地时回到出发地,见到自己。
其实就是判断是不是存在负环,用Bellman-Ford算法 求就可以了。
当图中存在负权环时,就能够在出发之前回到出发地,见着自己,将虫洞的权值变成其相反数,然后再用Bellman-Ford算法求解就可以了。
代码:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <string>
#include <algorithm>
const long long N = 500+10,M = 5210, MAX = 100000;
using namespace std;
typedef struct Edge
{
int u, v, weight;
}Edge;
Edge edge[M];
int dis[N], nodenum, edgenum, wormnum, cnt;
bool Bellman_Ford()
{
for (int i = 1; i < nodenum; i++)
{
for (int j = 0; j < cnt; j++)
{
if (dis[edge[j].v] > dis[edge[j].u] + edge[j].weight)
{
dis[edge[j].v] = dis[edge[j].u] + edge[j].weight;
}
}
}
for(int i = 0; i < cnt; i++)
{
if (dis[edge[i].v] > dis[edge[i].u] + edge[i].weight)
{
return true;
}
}
return false;
}
int main()
{
#ifndef ONLINE_JUDGE
freopen("1.txt", "r", stdin);
#endif
int i, j, F, s, e, t;
cin >> F;
while(F--)
{
cin >> nodenum >> edgenum >> wormnum;
cnt = 0;
for (i = 1; i <= edgenum; i++)
{
cin >> edge[cnt].u >> edge[cnt].v >> edge[cnt].weight;
cnt++;
edge[cnt].u = edge[cnt-1].v;
edge[cnt].v = edge[cnt-1].u;
edge[cnt].weight = edge[cnt-1].weight;
cnt++;
}
for (i = 1; i <= wormnum; i++)
{
cin >> edge[cnt].u >> edge[cnt].v >> edge[cnt].weight;
edge[cnt].weight *= -1;
cnt++;
}
for (i = 1; i <= nodenum; i++)
{
dis[i] = MAX;
}
if (Bellman_Ford())
{
cout << "YES" << endl;
}
else
{
cout << "NO" << endl;
}
}
return 0;
}