POJ2387Til the Cows Come Home(最短路问题Bellman-Ford解法)

Til the Cows Come Home

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 52332 Accepted: 17678

Description

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. 

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. 

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N 

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS: 

There are five landmarks. 

OUTPUT DETAILS: 

Bessie can get home by following trails 4, 3, 2, and 1.

Source

USACO 2004 November

题目大意:求1到n的最短路问题

解题思路:趁着外出比赛之前,写一下最短路问题,这个是Bellman-Ford解法

这个解法可以判是否有负权回路,所以比较厉害

#include<iostream>    
#include<cstdio>  
#include<stdio.h>  
#include<cstring>    
#include<cstdio>    
#include<climits>    
#include<cmath>   
#include<vector>  
#include <bitset>  
#include<algorithm>    
#include <queue>  
#include<map>  
using namespace std;

#define inf 9999999;
struct L
{
	int x, sum;
}lu, l;
vector<L> tu[10005];
queue<int> qua;
long long int a[10005][10005], dis[10005];
bool check[10005];
int n, i, j, m, k, x, y;
int main()
{
	cin >> m >> n;
	memset(check, false, sizeof(check));
	for (i = 1; i <= n; i++)
	{
		dis[i] = inf;
		for (j = 1; j <= n; j++)
		{
			if (i == j)
				a[i][j] = 0;
			else
				a[i][j] = inf;
		}
	}
	dis[1] = 0;
	for (i = 1; i <= m; i++)
	{
		cin >> x >> y >> k;
		l.x = y;
		l.sum = k;
		tu[x].push_back(l);
		l.x = x;
		tu[y].push_back(l);
	}
	qua.push(1);
	while (!qua.empty())
	{
		k = qua.front();
		check[k] = false;
		qua.pop();
		for (i = 0; i < tu[k].size(); i++)
		{
			l = tu[k][i];
			if (l.sum + dis[k] < dis[l.x])
			{
				dis[l.x] = l.sum + dis[k];
				if (check[l.x] != true)
				{
					check[l.x] = true;
					qua.push(l.x);
				}
			}
		}
	}
	cout << dis[n] << endl;
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/qq_34826781/article/details/71104877
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞