poj 2387 Til the Cows Come Home多种用法详解【dij vector||spfa||bellman_ford】

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input * Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100. Output * Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1. Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

题意:求 1 – > n 的最短路径;

思路:虽然本题是水题,但是zz在这里阐述几个解法来操作最短路(参考大神博客),以及zz解MST的 prim 算法和 Dijkstra 解最短路异同的见解;(松弛:用现在已得的最小路径去更新其他的路径;)

spfa邻接表写法:

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
#define max_n 200010
#define INF 0x3f3f3f3f
using namespace std;
typedef long long LL;
int head[max_n], dis[max_n];
int t, v, cnt;

struct node  {
	int to;
	int next;
	int cost;
}edge[max_n];

void addedge(int u, int v, int cot) {
	edge[cnt].to = v;
	edge[cnt].next = head[u];
	edge[cnt].cost = cot;
	head[u] = cnt++;
}

void spfa(int x) {
	queue<int> q;
	dis[x] = 0;
	q.push(x);
	while(!q.empty()) {
		int ant = q.front();
		q.pop();
		int u = head[ant];
		for(int i = u; i != -1; i = edge[i].next) {
			int res = dis[ant] + edge[i].cost;
			if(res < dis[edge[i].to]) {
				dis[edge[i].to] = res;
				q.push(edge[i].to);
			}
		}
	}
	printf("%d\n", dis[v]);
}

int main() {
	while(scanf("%d %d", &t, &v) != EOF) {
		cnt = 0;
		memset(head, -1, sizeof(head));
		memset(dis, INF, sizeof(dis));
		while(t--) {
			int p1, p2, cos;
			scanf("%d %d %d", &p1, &p2, &cos);
			addedge(p1, p2, cos);
			addedge(p2, p1, cos);
		}
		spfa(1);
	}
	return 0;
}

dij + vector优化:

#include<cstdio>
#include<cstring>
#include<queue>
#include<vector>
#include<algorithm>
using namespace std;
#define INF 0x3f3f3f3f
#define max_n 1010
int V,T;
int d[max_n];

struct edge
{
	int to;
	int cost;
}E;

typedef pair<int ,int> P;
vector<edge> G[max_n];

bool operator<(P x,P y)
{
	return x.first>y.first;
}

void dij(int s,vector<edge> *G)
{
	priority_queue<P> que;
	fill(d,d+V+1,INF);
	d[s]=0;
	que.push(P(0,s));
	while(!que.empty())
	{
		P p=que.top();
		que.pop();
		int v=p.second;
		if(d[v]<p.first) continue;
		for(int i=0;i<G[v].size();i++)
		{
			edge e=G[v][i];
			if(d[v]+e.cost<d[e.to])
			{
				d[e.to]=d[v]+e.cost;
				que.push(P(d[e.to],e.to));
			}
		}
	}
}

int main()
{
	while(~scanf("%d %d",&T,&V))
	{
		
		int s;
		while(T--)
		{
			scanf("%d %d %d",&s,&E.to,&E.cost);
			
			int t=2;
			while(t--)
			{
				G[s].push_back(E);
				int tmp=s;
				s=E.to,E.to=tmp;
			}
		}
		dij(1,G);
		printf("%d\n",d[V]);
	}
	return 0;
}

dij不优化:

//dijkstra解法(权值不能为负),前几篇解MST时选择lowcost数组来判别,此代码用mst数组来判别,dijkstra和prim差别较小
#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
int graph[1010][1010];
void dijkstra(int n)
{
	int lowcost[1010],mst[1010];
	int i,j,min,minid;
	memset(mst,0,sizeof(mst));
	mst[1]=1;
	for(i=2;i<=n;i++)
		lowcost[i]=graph[1][i];
	for(i=2;i<=n;i++)
	{
		min=INF;
		for(j=2;j<=n;j++)
		{
			if(!mst[j] && lowcost[j]<min)
			{
				min=lowcost[j];
				minid=j;
			}
		}
		mst[minid]=1;                                                                                                              for(j=1;j<=n;j++)//MST时,另加一行,用sum+=min,存储最小权值之和;
		{
			int ans=graph[minid][j]+lowcost[minid];//和MST的prim区别之处,这也是易变之处;
			if(!mst[j] && ans<lowcost[j])
				lowcost[j]=ans;
		}
	}
	printf("%d\n",lowcost[n]);
}
int main()
{
	int m,n,i,j,cost;
	while(scanf("%d %d",&m,&n)!=EOF)
	{
		memset(graph,INF,sizeof(graph));
		for(i=1;i<=n;i++)
			graph[i][i]=0;
		while(m--)
		{
			scanf("%d %d %d",&i,&j,&cost);
			if(graph[i][j]>cost) 
				graph[i][j]=graph[j][i]=cost;
		}
		dijkstra(n);
	}
	return 0;
}
//bellman-ford(权值可以为负)  ,构造结构体,和Kruskal 相似; 
#include<stdio.h>
#include<string.h>
#define INF 0x3f3f3f3f
struct node
{
	int a;
	int b;
	int c;
}s[3000];
void bellman_ford(int n,int m)
{
	int mst[3000];
	memset(mst,INF,sizeof(mst));
	mst[1]=0;//mst[i]=0,代表i为起点;
	for(int i=1;i<=n;i++)
	{
		for(int j=1;j<=m;j++)
		{
			if(mst[s[j].a]>s[j].c+mst[s[j].b])
				mst[s[j].a]=s[j].c+mst[s[j].b];
			if(mst[s[j].b]>s[j].c+mst[s[j].a])
				mst[s[j].b]=s[j].c+mst[s[j].a];
		}
	}
	printf("%d\n",mst[n]);//代表n为终点,n可变;
}
int main()
{
	int n,m,a,b,c;
	while(scanf("%d %d",&m,&n)!=EOF)
	{
		for(int i=1;i<=m;i++)
   			scanf("%d %d %d",&s[i].a,&s[i].b,&s[i].c);
		bellman_ford(n,m);
	}
	return 0;
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/qq_36368339/article/details/55001204
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞