While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2.. M+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2.. M+ W+1 of each farm: Three space-separated numbers ( S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1.. F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2 3 3 1 1 2 2 1 3 4 2 3 1 3 1 3 3 2 1 1 2 3 2 3 4 3 1 8
Sample Output
NO YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题意:
一个人能否从一个起点出发, 走回来时间会不会倒流。
因为此题存在负权边的问题, 所以迪杰斯特拉算法行不通, 所以需要用Bellman-Ford来求, 但这个题目的意思并不是让你求最短路径, 而是转换成了是否会有负权环的问题。
所以在用完Bellman-Ford后, 利用负权边的判断来给出题目答案。
代码如下:
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <iostream>
using namespace std;
const int maxn=5505;
const int INF=0x3f3f3f3f;
int f;
int n,m,w;
struct edge
{
int s;
int len;
int e;
};
edge e[maxn];
int d[maxn];
int num;
//Bellman-Ford算法
bool Bellman (int s)
{
for (int i=1;i<=n;i++)
{
if(i==s)
d[i]=0;
else
d[i]=INF;
}
for (int i=1;i<n;i++)
{
for (int j=0;j<num;j++)
{
if(d[e[j].e]>d[e[j].s]+e[j].len)
d[e[j].e]=d[e[j].s]+e[j].len;
}
}
//题目的关键所在
for (int i=0;i<num;i++)
if(d[e[i].e]>d[e[i].s]+e[i].len)
return true;
return false;
}
int main()
{
scanf("%d",&f);
while (f--)
{
num=0;
scanf("%d%d%d",&n,&m,&w);
for (int i=0;i<m;i++)
{
int x,y,len;
scanf("%d%d%d",&x,&y,&len);
e[num].s=x;
e[num].len=len;
e[num++].e=y;
e[num].s=y;
e[num].len=len;
e[num++].e=x;
}
for (int i=0;i<w;i++)
{
int x,y,len;
scanf("%d%d%d",&x,&y,&len);
e[num].s=x;
e[num].len=-len;
e[num++].e=y;
}
if(Bellman(1))
printf("YES\n");
else
printf("NO\n");
}
return 0;
}