Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
题目大意
第一行 输入一个数 是表示几组测试数据
第二行 三个数 N(点的个数),M(正边的个数),W(负边的个数) 注意 :正边为双向的,负边为单向的。然后 M行u,v,w,再然后W行u,v,w。求这个图是不是存在负环。 有 YES 没NO。
参考代码
#include <iostream>
#include <cstdio>
#define INF 0x3f3f3f
using namespace std;
int dis[1005];
int n, m, k, t;
struct node
{
int v, u, w;
}a[5005];
bool bellmanFord()
{
for (int i = 1;i <= n - 1;i++)
{
int flag = 0;
for (int j = 1;j <= m;j++)
{
if (dis[a[j].u] > dis[a[j].v] + a[j].w)
{
dis[a[j].u] = dis[a[j].v] + a[j].w;
flag = 1;
}
}
if (!flag)
break;
}
for (int j = 1;j <= m;j++)
{
if (dis[a[j].u] > dis[a[j].v] + a[j].w)
{
return true;
}
}
return false;
}
int main()
{
scanf("%d", &t);
while (t--)
{
scanf("%d %d %d", &n, &m, &k);
for (int i = 1;i <= n;i++)
dis[i] = INF;
for (int i = 1;i <= m;i++)
{
scanf("%d %d %d", &a[i].u, &a[i].v, &a[i].w);
a[i + m].v = a[i].u;
a[i + m].u = a[i].v;
a[i + m].w = a[i].w;
}
m = 2 * m + 1;
for (int i = m;i < m + k;i++)
{
scanf("%d %d %d", &a[i].u, &a[i].v, &a[i].w);
a[i].w = -a[i].w;
}
m += k;
dis[1] = 0;
if (bellmanFord())
printf("YES\n");
else
printf("NO\n");
}
}