Arbitrage(bellman-Ford)

Description
Arbitrage is the use of discrepancies in currency exchange rates to transform one unit of a currency into more than one unit of the same currency. For example, suppose that 1 US Dollar buys 0.5 British pound, 1 British pound buys 10.0 French francs, and 1 French franc buys 0.21 US dollar. Then, by converting currencies, a clever trader can start with 1 US dollar and buy 0.5 * 10.0 * 0.21 = 1.05 US dollars, making a profit of 5 percent.

Your job is to write a program that takes a list of currency exchange rates as input and then determines whether arbitrage is possible or not.
Input
The input will contain one or more test cases. Om the first line of each test case there is an integer n (1<=n<=30), representing the number of different currencies. The next n lines each contain the name of one currency. Within a name no spaces will appear. The next line contains one integer m, representing the length of the table to follow. The last m lines each contain the name ci of a source currency, a real number rij which represents the exchange rate from ci to cj and a name cj of the destination currency. Exchanges which do not appear in the table are impossible.
Test cases are separated from each other by a blank line. Input is terminated by a value of zero (0) for n.
Output
For each test case, print one line telling whether arbitrage is possible or not in the format “Case case: Yes” respectively “Case case: No”.
Sample Input
3
USDollar
BritishPound
FrenchFranc
3
USDollar 0.5 BritishPound
BritishPound 10.0 FrenchFranc
FrenchFranc 0.21 USDollar

3
USDollar
BritishPound
FrenchFranc
6
USDollar 0.5 BritishPound
USDollar 4.9 FrenchFranc
BritishPound 10.0 FrenchFranc
BritishPound 1.99 USDollar
FrenchFranc 0.09 BritishPound
FrenchFranc 0.19 USDollar

0
Sample Output
Case 1: Yes
Case 2: No
还是汇率问题,唯一不同的是字符串代表点了,用map映射一下。

#include<cstdio>
#include<cstring>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<string>
#include<cmath>
#include<set>
#include<map>
#include<vector>
using namespace std;
typedef long long ll;
const int inf = 0x3f3f3f3f;
const int maxn = 1005;
int cnt,head[33];
double d[33];
string a,b;
map<string ,int>mp;
struct Node
{
    int u,v,next;
    double w;
}node[1005];
void add_edge(int u,int v,double w,int tot)
{
    node[tot].u = u;node[tot].v = v;
    node[tot].w = w;
    node[tot].next = head[u];
    head[u] = tot;
}
void relax(int u,int v,double w)
{
    d[v] = max(d[v],d[u]*w);
}
int main()
{
    #ifdef LOCAL
    freopen("C:\\Users\\巍巍\\Desktop\\in.txt","r",stdin);
    //freopen("C:\\Users\\巍巍\\Desktop\\out.txt","w",stdout);
    #endif // LOCAL
    int n,kase = 1;
    while(scanf("%d",&n) != EOF)
    {
        if(n == 0)break;
        printf("Case %d: ",kase++);
        cnt = 1;
        for(int i = 1;i <= n;i++)head[i] = -1;
        for(int i = 1;i <= n;i++)
        {
            cin >> a;
            mp[a] = cnt++;
        }
        int m;
        scanf("%d",&m);
        for(int i = 1;i <= m;i++)
        {
            double r;
            cin >> a >> r >> b;
            int u = mp[a];
            int v = mp[b];
            add_edge(u,v,r,i);
        }
        for(int i = 1;i <= n;i++)d[i] = 0;
        d[1] = 1;
        for(int i = 1;i < n;i++)
        {
            for(int j = 1;j <= m;j++)
            {
                relax(node[j].u,node[j].v,node[j].w);
            }
        }
        bool flag = 0;
        for(int i = 1;i <= m;i++)
        {
            int from = node[i].u;
            int to = node[i].v;
            if(d[to] < d[from]*node[i].w)
            {
                flag = 1;break;
            }
        }
        if(flag)
            printf("Yes\n");
        else
            printf("No\n");
    }
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/Techay/article/details/49232953
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞