POJ3259 Wormholes(Bellman-ford 负环)

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 33194 Accepted: 12085

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer,
F.
F farm descriptions follow.

Line 1 of each farm: Three space-separated integers respectively:
N,
M, and
W

Lines 2..
M+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: a bidirectional path between
S and
E that requires
T seconds to traverse. Two fields might be connected by more than one path.

Lines
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S,
E,
T) that describe, respectively: A one way path from
S to
E that also moves the traveler back
T seconds.

Output

Lines 1..
F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time.

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

解题思路:

还是运用bellman-ford算法,求负环。


代码如下:

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn = 10000;  //开了5002 RE,索性爆炸点开个10000.

#define inf 100000000

int all; //表示边数
int n,m,w; //分别表示顶点数,邻接边,虫洞个数
int cnt;

struct point
{
    int start;
    int end;
    int seconds;
} a[maxn];

int dis[maxn];

bool bellman()
{
    int i,j;
    bool flag;
    memset(dis,inf,sizeof(dis));
    dis[0] = 0;
    for(i=1; i<n; i++)  //因为0这个点已经初始化,所以从1这个点开始
    {
        flag = false;
        for(j=0; j< all; j++)   //all为总的边数,包含虫洞
        {
            if(dis[a[j].start] > dis[a[j].end] + a[j].seconds)
            {
                dis[a[j].start] = dis[a[j].end] + a[j].seconds;
                flag = true;
            }
        }
        if(!flag)
        {
            break;
        }
    }
    for(j=0; j<all; j++)
    {
        if(dis[a[j].start] > dis[a[j].end] + a[j].seconds)
        {
            dis[a[j].start] = dis[a[j].end] + a[j].seconds;
            return true;  //存在负环
        }
    }
    return false; //不存在负环,也就是回不去
}

int main()
{
    int F,i;
    int num1,num2,seconds;
    //freopen("111","r",stdin);
    cin>>F;
    while(F--)
    {
        all = 0;
        cin>>n>>m>>w;
        for(i=0; i<m; i++) //普通的道路
        {
            cin>>num1>>num2>>seconds;
            a[all].start = num1;
            a[all].end = num2;
            a[all++].seconds = seconds;
            a[all].start = num2;
            a[all].end = num1;
            a[all++].seconds = seconds;
        }
        for(i=0; i<w; i++)
        {
            cin>>num1>>num2>>seconds;
            a[all].start = num1;
            a[all].end = num2;
            a[all++].seconds = -seconds;
        }
        if(bellman())
        {
            cout<<"YES"<<endl;
        }
        else
        {
            cout<<"NO"<<endl;
        }
    }
    return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/u013021513/article/details/44276655
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞