POJ3259 Wormholes SPFA 或者 bellman_ford

Wormholes

Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 37539 Accepted: 13818

Description

While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..NM (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.

As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .

To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.

Input

Line 1: A single integer, 
F
F farm descriptions follow. 

Line 1 of each farm: Three space-separated integers respectively: 
N
M, and 
W 

Lines 2..
M+1 of each farm: Three space-separated numbers (
S
E
T) that describe, respectively: a bidirectional path between 
S and 
E that requires 
T seconds to traverse. Two fields might be connected by more than one path. 

Lines 
M+2..
M+
W+1 of each farm: Three space-separated numbers (
S
E
T) that describe, respectively: A one way path from 
S to 
E that also moves the traveler back 
T seconds.

Output

Lines 1..
F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).

Sample Input

2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8

Sample Output

NO
YES

Hint

For farm 1, FJ cannot travel back in time. 

For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.

求是否存在负权值回路

#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>
const int INF = (1<<30);
using namespace std;

struct Node
{
    int v,w,nt;
}f[100009];

int cnt;
int used[100009];
int head[100009];
int inq[100009];
int dis[100009];
queue<int>q;

void add(int u,int v,int w)
{
    f[cnt].v=u;
    f[cnt].w=w;
    f[cnt].nt=head[v];
    head[v]=cnt++;
}

int spfa(int n)
{
    for(int i=1;i<=n;i++)
        dis[i]=INF;
    dis[1]=0;

    q.push(1);
    used[1]++;

    while(!q.empty())
    {
        int x=q.front(); q.pop();
        inq[x]=0;
        for(int u=head[x]; u!=-1; u=f[u].nt)
        {
            if(dis[f[u].v] > dis[x]+f[u].w)//如果可松弛则进行操作,否则不动
            {
                dis[f[u].v] = dis[x]+f[u].w;
                if(!inq[f[u].v])
               {
                inq[f[u].v]=1;
                if(++used[f[u].v]>n-1) return 0;
                q.push(f[u].v);
               }
            }
        }
    }
    return 1;
}

void init(int n)
{
    cnt=0;
    for(int i=1;i<=n;i++)
    {
        used[i]=0;
        inq[i]=0;
        head[i]=-1;
    }
}

int main()
{
    int T;
    int u,v,w;
    int n,m,l;

    scanf("%d",&T);
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&l);

        init(n);

        for(int i=0;i<m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }

        for(int i=0;i<l;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,-w);
        }

        if(!spfa(n)) puts("YES");
        else puts("NO");
    }

    return 0;
}


#include <iostream>
#include <stdio.h>
#include <string>
#include <cstring>
#include <algorithm>
#include <cmath>

using namespace std;
const int INF = (1<<26);

struct Node
{
    int u,v,w;
}f[10009];

int cnt;
int dis[10009];

void add(int u,int v,int w)
{
    f[cnt].u=u;
    f[cnt].v=v;
    f[cnt++].w=w;
}

int bellman_ford(int n)
{
    for(int i=1;i<=n;i++) dis[i]=INF;

    dis[1]=0;
    int u,v,w;

    for(int i=0;i<n-1;i++)
        for(int j=0;j<cnt;j++)
        {
             u=f[j].u;
             v=f[j].v;
             w=f[j].w;

            if(dis[u]<INF && dis[v]>dis[u]+w)
            {
                dis[v]=dis[u]+w;
            }
        }

    for(int j=0;j<cnt;j++)
        {
             u=f[j].u;
             v=f[j].v;
             w=f[j].w;

            if(dis[u]<INF && dis[v]>dis[u]+w)
            {
               return 0;
            }
        }
        return 1;
}

int main()
{
    int T;
    scanf("%d",&T);
    int n,m,l;
    while(T--)
    {
        scanf("%d%d%d",&n,&m,&l);
        cnt=0;
        int u,v,w;

        for(int i=1;i<=m;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,w);
            add(v,u,w);
        }

        for(int i=0;i<l;i++)
        {
            scanf("%d%d%d",&u,&v,&w);
            add(u,v,-w);
        }

        if(bellman_ford(n)==0) puts("YES");
        else puts("NO");

    }
    return 0;
}

    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/wust_ZJX/article/details/48916355
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞