Wormholes
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 53846 Accepted: 20049
Description
While exploring his many farms, Farmer John has discovered a number of amazing wormholes. A wormhole is very peculiar because it is a one-way path that delivers you to its destination at a time that is BEFORE you entered the wormhole! Each of FJ’s farms comprises N (1 ≤ N ≤ 500) fields conveniently numbered 1..N, M (1 ≤ M ≤ 2500) paths, and W (1 ≤ W ≤ 200) wormholes.
As FJ is an avid time-traveling fan, he wants to do the following: start at some field, travel through some paths and wormholes, and return to the starting field a time before his initial departure. Perhaps he will be able to meet himself :) .
To help FJ find out whether this is possible or not, he will supply you with complete maps to F (1 ≤ F ≤ 5) of his farms. No paths will take longer than 10,000 seconds to travel and no wormhole can bring FJ back in time by more than 10,000 seconds.
Input
Line 1: A single integer, F. F farm descriptions follow.
Line 1 of each farm: Three space-separated integers respectively: N, M, and W
Lines 2..M+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: a bidirectional path between S and E that requires T seconds to traverse. Two fields might be connected by more than one path.
Lines M+2..M+W+1 of each farm: Three space-separated numbers (S, E, T) that describe, respectively: A one way path from S to E that also moves the traveler back T seconds.
Output
Lines 1..F: For each farm, output “YES” if FJ can achieve his goal, otherwise output “NO” (do not include the quotes).
Sample Input
2
3 3 1
1 2 2
1 3 4
2 3 1
3 1 3
3 2 1
1 2 3
2 3 4
3 1 8
Sample Output
NO
YES
Hint
For farm 1, FJ cannot travel back in time.
For farm 2, FJ could travel back in time by the cycle 1->2->3->1, arriving back at his starting location 1 second before he leaves. He could start from anywhere on the cycle to accomplish this.
题意:他的农场中,有很多fields,field之间有很多path,以及wormholes,通过path在field之间来回移动需要花费时间,通过wormholes移动则会时光倒流.求他能否找到一条路径回到原地后时光倒流
分析:实质就是求单元最短路中有无负权回路,输入数据后直接代公式
/* * Filename: code.cpp * Created: 2017-08-09 * Author: wyl6 *[mail:17744454343@163.com] * Desciption: Desciption */
#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;
#define INT_MAX 1 << 30
#define MAX 100
typedef long long ll;
int f;
int n,m,w;
int k;
struct edge{int from,to,cost;};
edge es[6000];
int dis[600];
void solve()
{
for (int i = 0; i < n; i += 1) dis[i] = 0;
for (int i = 0; i < n; i += 1){
for (int j = 0; j < k; j += 1){
edge e = es[j];
if (dis[e.to] > dis[e.from]+e.cost){
dis[e.to] = dis[e.from]+e.cost;
if (i == n-1){
printf("YES\n");
return;
}
}
}
}
printf("NO\n");
}
int main(int argc, char const* argv[])
{
scanf("%d",&f);
while (f--){
int s,e,t;
k = 0;
scanf("%d%d%d",&n,&m,&w);
for (int i = 0; i < m; i += 1){
scanf("%d%d%d",&s,&e,&t);
es[k].from = es[k+1].to = s;
es[k].to = es[k+1].from = e;
es[k].cost = es[k+1].cost = t;
k += 2;
}
for (int i = 0; i < w; i += 1){
scanf("%d%d%d",&s,&e,&t);
es[k].from = s;
es[k].to = e;
es[k].cost = -t;
k++;
}
solve();
}
return 0;
}
后记:这题中,k的操作和循环的控制容易出错