poj1860(Bellman-Ford变形,含负权的单源最短路径,判断是否有正权环)

Currency Exchange
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 24879 Accepted: 9059

Description
Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency.
For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR.
You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real RAB, CAB, RBA and CBA – exchange rates and commissions when exchanging A to B and B to A respectively.
Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations.

Input
The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=103.
For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10-2<=rate<=102, 0<=commission<=102.
Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 104.

Output
If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
题意:有n个货币,m个交换点,然后刚开始拥有v个单元的s货币,问经过一系列交换货币能否是货币的价值增加,最终要回到s,网上百度了下,用Bellman-Ford算法求单源最短路径,并判断是否有正环,如果有正环也就意味着货币的价值可以增长到无穷大,所以也就可以增加了。图的任意一条最短路径既不能包含负权回路,也不会包含正权回路,因此它最多包含n-1条边。从s出发进行第一次取点,也就是从s的第一层的路劲,所以最短路径最多包含n-1条边,进行n-1次取点比较就可以判断是否含有正权回路。

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const double MIN=0.0; 
struct Edge{
    int u,v;
    double r,c;
};
Edge edge[205];
double dist[105],v;
int n,m,s,e;
void init(int u,int v,double r,double c){
    edge[e].u=u;
    edge[e].v=v;
    edge[e].r=r;
    edge[e].c=c;
    e++;
}

bool Bellman_Ford(){
    int i,j;
    memset(dist,MIN,sizeof(dist));
    dist[s]=v;
    for(i=1;i<=n-1;i++){
        bool flag=false;
        for(j=1;j<=e;j++){
            if(dist[edge[j].v]<(dist[edge[j].u]-edge[j].c)*edge[j].r){
                dist[edge[j].v]=(dist[edge[j].u]-edge[j].c)*edge[j].r;
                flag=true;
            }

        }
        if(dist[s]>v)return true;
        //printf("--dist--\n");
        if(!flag)return false;

    }
    //printf("--dist--\n");
    for(j=1;j<=e;j++){
        if(dist[edge[j].v]<(dist[edge[j].u]-edge[j].c)*edge[j].r){
            dist[edge[j].v]=(dist[edge[j].u]-edge[j].c)*edge[j].r;
            return true;
        }

    }
    if(dist[s]>v)return true;
    //printf("----\n");
    return false;
}

int main(){
    double r1,c1,r2,c2;
    int i,j,a,b;

        scanf("%d%d%d%lf",&n,&m,&s,&v);
        e=1;
        for(i=1;i<=m;i++){
            scanf("%d%d%lf%lf%lf%lf",&a,&b,&r1,&c1,&r2,&c2);
            init(a,b,r1,c1);
            init(b,a,r2,c2);
        }
        if(Bellman_Ford())printf("YES\n");
        else printf("NO\n");

    return 0;
} 
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/ydm1234/article/details/51165223
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞