Currency Exchange(Bellman-Ford)

A – Currency Exchange
Time Limit:1000MS     Memory Limit:30000KB     64bit IO Format:%I64d & %I64u
Submit 
Status 
Practice 
POJ 1860 Appoint description:  System Crawler  (2015-10-10)

Description

Several currency exchange points are working in our city. Let us suppose that each point specializes in two particular currencies and performs exchange operations only with these currencies. There can be several points specializing in the same pair of currencies. Each point has its own exchange rates, exchange rate of A to B is the quantity of B you get for 1A. Also each exchange point has some commission, the sum you have to pay for your exchange operation. Commission is always collected in source currency. 

For example, if you want to exchange 100 US Dollars into Russian Rubles at the exchange point, where the exchange rate is 29.75, and the commission is 0.39 you will get (100 – 0.39) * 29.75 = 2963.3975RUR. 

You surely know that there are N different currencies you can deal with in our city. Let us assign unique integer number from 1 to N to each currency. Then each exchange point can be described with 6 numbers: integer A and B – numbers of currencies it exchanges, and real R 
AB, C 
AB, R 
BA and C 
BA – exchange rates and commissions when exchanging A to B and B to A respectively. 

Nick has some money in currency S and wonders if he can somehow, after some exchange operations, increase his capital. Of course, he wants to have his money in currency S in the end. Help him to answer this difficult question. Nick must always have non-negative sum of money while making his operations. 

Input

The first line of the input contains four numbers: N – the number of currencies, M – the number of exchange points, S – the number of currency Nick has and V – the quantity of currency units he has. The following M lines contain 6 numbers each – the description of the corresponding exchange point – in specified above order. Numbers are separated by one or more spaces. 1<=S<=N<=100, 1<=M<=100, V is real number, 0<=V<=10 
3

For each point exchange rates and commissions are real, given with at most two digits after the decimal point, 10 
-2<=rate<=10 
2, 0<=commission<=10 
2

Let us call some sequence of the exchange operations simple if no exchange point is used more than once in this sequence. You may assume that ratio of the numeric values of the sums at the end and at the beginning of any simple sequence of the exchange operations will be less than 10 
4

Output

If Nick can increase his wealth, output YES, in other case output NO to the output file.

Sample Input

3 2 1 20.0
1 2 1.00 1.00 1.00 1.00
2 3 1.10 1.00 1.10 1.00

Sample Output

YES
思路:
   这题就是找是否存在正环,因为存在正环的话肯定存在一种钱会无穷增大,所以无论是否是想要的那种币,都可以用那个无穷的钱去换它,而赚钱。
AC代码:
#include<iostream>
#include<algorithm>
#include<cstdlib>
#include<cstring>
#include<string>
#include<cstdio>
#include<vector>
#include<cmath>
#include<map>
using namespace std;
#define T 1050
#define inf 0x3f3f3f3f
#define CRL(a) memset(a,0,sizeof(a))
typedef long long ll;
struct node
{
	int u,v;
	double r,c;
}a[T];
int n,m;
double sum[T];
int main()
{
	/*freopen("input.txt","r",stdin);*/
	int i,k,b,c,ans;
	double t,ra,rb,ca,cb;
	while(~scanf("%d%d%d%lf",&n,&k,&m,&t))
	{
		CRL(sum);sum[m]=t;ans=0;
		for(i=0;i<k;++i){
			scanf("%d%d%lf%lf%lf%lf",&b,&c,&ra,&ca,&rb,&cb);
			a[ans].u = b;
			a[ans].v = c;
			a[ans].r = ra,a[ans].c = ca;
			ans++;
			a[ans].u = c;
			a[ans].v = b;
			a[ans].r = rb,a[ans].c = cb;
			ans++;
			/*
			用这种方法存储就Wa了????
			a[b].next = c;
			a[b].r = ra,a[b].c = ca;
			a[c].next = b;
			a[c].r = rb,a[c].c = cb;
			*/
		}
		int flag = 0;
		for(i=1;i<n;++i)
			for(k=0;k<ans;++k){
				if(sum[a[k].v]<(sum[a[k].u]-a[k].c)*a[k].r)
					sum[a[k].v]=(sum[a[k].u]-a[k].c)*a[k].r;
			}
				for(i=0;i<ans;++i)
					if(sum[a[i].v]<(sum[a[i].u]-a[i].c)*a[i].r)
						flag=1;
				if(flag)
					printf("YES\n");
				else
					printf("NO\n");
		
	}
	return 0;
}
    原文作者:Bellman - ford算法
    原文地址: https://blog.csdn.net/zsc2014030403015/article/details/49054061
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞