最短路径(3)--poj2253(Dijkstra变形题)

Frogger

                                                  Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%lld & %llu

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists’ sunscreen, he wants to avoid swimming and instead reach her by jumping.

Unfortunately Fiona’s stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps.

To execute a given sequence of jumps, a frog’s jump range obviously must be at least as long as the longest jump occuring in the sequence.

The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones.

You are given the coordinates of Freddy’s stone, Fiona’s stone and all other stones in the lake. Your job is to compute the frog distance between Freddy’s and Fiona’s stone.

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy’s stone, stone #2 is Fiona’s stone, the other n-2 stones are unoccupied. There’s a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying “Scenario #x” and a line saying “Frog Distance = y” where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

Hint

        这道题题目大意,有两只青蛙,分别在两个石头上,青蛙A想要到青蛙B那儿去,他可以直接跳到B的石头上,也可以跳到其他石头上,再从其他石头跳到B那儿,求青蛙从A到B的所有路径中最小的Frog Distance,我们定义Frog Distance为从A到B的一条路径中所跳的最大距离,例如,如果从A到B某条路径跳的距离是2,5,6,4,则Frog Distance就是6,题目输入的第一行代表石头的个数,当个数为0时结束程序,接着有n行,其中第2,3行分别代表A,B青蛙的坐标,其他n-2行分别代表空的石头的坐标,输出一个小数(保留三位),具体格式参见样例,注意没输出一个答案还要再空一行。
题目数据1很明显为5.000
对于数据2青蛙有两种方案
方案1:1-2则经过距离为2.000故此时Frog Distance=2.000
方案2:1-3-2 则经过距离分别是1.414 1.414 故此时Frog Distance=1.414
故所求的最小的Frog Distance=1.414
这道题和上一道题POJ1797很相似,那个是求最大生成树的最小权,这个是求最小生成树的最大权,大同小异,同样是Dijkstra变形。代码如下:

#include<stdio.h>
#include<math.h>
struct node
{
	float x,y;
};
node map[205];
int vis[205];
float dis[205];
float mpt[205][205];
int n;
float Max(float a,float b)
{
	return a>b?a:b;
}
void Dij()
{
	int i,j;
	for(i=0;i<n-1;i++)
	{
		float min=1000000000;
		int u=-1;
		for(j=0;j<n-1;j++)
		{
			if(!vis[j]&&min>dis[j])
			{
				min=dis[j];
				u=j;
			}
		}
		if(u==-1)break;
		vis[u]=1;
		for(j=0;j<n-1;j++)                                  
		{
			if(!vis[j]&&Max(dis[u],mpt[u][j])<dis[j])       //更新条件
			{
				dis[j]=Max(dis[u],mpt[u][j]);
			}
		}
	}
}
int main()
{
	int i,j;
	node s,e;        //起始点
	int cnt=0;
	while(scanf("%d",&n))
	{
		if(!n)break;
		scanf("%f %f",&s.x,&s.y);
		scanf("%f %f",&e.x,&e.y);
		for(i=0;i<n-2;i++)
		{
			scanf("%f %f",&map[i].x,&map[i].y);
			vis[i]=0;
			dis[i]=sqrt((s.x-map[i].x)*(s.x-map[i].x)+(s.y-map[i].y)*(s.y-map[i].y));
		}
		map[i]=e;
		vis[i]=0;
		dis[i]=sqrt((s.x-e.x)*(s.x-e.x)+(s.y-e.y)*(s.y-e.y));
		for(i=0;i<n-1;i++)
		{
			for(j=0;j<n-1;j++)
			{
				if(i==j)mpt[i][j]=0;
				else mpt[i][j]=sqrt((map[j].x-map[i].x)*(map[j].x-map[i].x)+(map[j].y-map[i].y)*(map[j].y-map[i].y));
			}
		}
		Dij();
		printf("Scenario #%d\nFrog Distance = %.3f\n\n",++cnt,dis[n-2]);
	}
	return 0;
}



    原文作者:Dijkstra算法
    原文地址: https://blog.csdn.net/Acmer_Sly/article/details/53328793
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞