HDU1548:A strange lift(Dijkstra && BFS)

Problem Description There is a strange lift.The lift can stop can at every floor as you want, and there is a number Ki(0 <= Ki <= N) on every floor.The lift have just two buttons: up and down.When you at floor i,if you press the button “UP” , you will go up Ki floor,i.e,you will go to the i+Ki th floor,as the same, if you press the button “DOWN” , you will go down Ki floor,i.e,you will go to the i-Ki th floor. Of course, the lift can’t go up high than N,and can’t go down lower than 1. For example, there is a buliding with 5 floors, and k1 = 3, k2 = 3,k3 = 1,k4 = 2, k5 = 5.Begining from the 1 st floor,you can press the button “UP”, and you’ll go up to the 4 th floor,and if you press the button “DOWN”, the lift can’t do it, because it can’t go down to the -2 th floor,as you know ,the -2 th floor isn’t exist.

Here comes the problem: when you are on floor A,and you want to go to floor B,how many times at least he has to press the button “UP” or “DOWN”?

 

Input The input consists of several test cases.,Each test case contains two lines.

The first line contains three integers N ,A,B( 1 <= N,A,B <= 200) which describe above,The second line consist N integers k1,k2,….kn.

A single 0 indicate the end of the input.  

Output For each case of the input output a interger, the least times you have to press the button when you on floor A,and you want to go to floor B.If you can’t reach floor B,printf “-1”.  

Sample Input

5 1 5 3 3 1 2 5 0  

Sample Output

3   题意:电梯每层有一个不同的数字,例如第n层有个数字k,那么这一层只能上k层或下k层,但是不能低于一层或高于n层,给定起点与终点,要求出最少要按几次键 思路:一开始的想法是搜索,而且搜索也是可行的,不过既然这道题出在了最短路的专题里面,自然也要尝试下最短路的做法,要注意的是,这道题是单向边,我们只要让map里面的值全部为1就可以统计次数了   首先是最短路的Dijkstra

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

const int inf = 1<<30;

int n;
int map[205][205];
int a[205],cnt;
int vis[205],cast[205];

void Dijkstra(int s,int e)
{
    int i,j,min,pos;
    memset(vis,0,sizeof(vis));
    for(i = 0; i<n; i++)
        cast[i] = map[s][i];
    cast[s] = 0;
    vis[s] = 1;
    for(i = 1; i<n; i++)
    {
        min = inf;
        for(j = 0; j<n; j++)
        {
            if(cast[j]<min && !vis[j])
            {
                pos = j;
                min = cast[j];
            }
        }
        if(min == inf)
            break;
        vis[pos] = 1;
        for(j = 0; j<n; j++)
        {
            if(cast[pos]+map[pos][j]<cast[j] && !vis[j])
                cast[j] = cast[pos]+map[pos][j];
        }
    }
}

int main()
{
    int i,j,s,e,x,y;
    while(~scanf("%d",&n),n)
    {
        scanf("%d%d",&s,&e);
        s--,e--;
        for(i = 0; i<n; i++)
            for(j = 0; j<n; j++)
                map[i][j] = inf;
        for(i = 0; i<n; i++)
        {
            scanf("%d",&a[i]);
            if(i+a[i]<n)
                map[i][i+a[i]] = 1;
            if(i-a[i]>=0)
                map[i][i-a[i]] = 1;
        }
        Dijkstra(s,e);
        printf("%d\n",cast[e]==inf?-1:cast[e]);
    }

    return 0;
}

  然后是BFS  

#include <stdio.h>
#include <string.h>
#include <algorithm>
#include <queue>
using namespace std;

int n,s,e;
int ss[205],vis[205];

struct node
{
    int x,step;
};

int check(int x)
{
    if(x<=0 || x>n)
    return 1;
    return 0;
}

int BFS()
{
    queue<node> Q;
    node a,next;
    int i;
    a.x = s;
    a.step = 0;
    vis[s] = 1;
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.front();
        Q.pop();
        if(a.x == e)
        return a.step;
        for(i = -1;i<=1;i+=2)
        {
            next = a;
            next.x +=i*ss[next.x];
            if(check(next.x) || vis[next.x])
            continue;
            vis[next.x] = 1;
            next.step++;
            Q.push(next);
        }
    }
    return -1;
}

int main()
{
    int i,j;
    while(~scanf("%d",&n),n)
    {
        scanf("%d%d",&s,&e);
        for(i = 1;i<=n;i++)
        scanf("%d",&ss[i]);
        memset(vis,0,sizeof(vis));
        printf("%d\n",BFS());
    }

    return 0;
}
    原文作者:Dijkstra算法
    原文地址: https://blog.csdn.net/libin56842/article/details/16949981
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞