Problem Description XX星球有很多城市,每个城市之间有一条或多条飞行通道,但是并不是所有的路都是很安全的,每一条路有一个安全系数s,s是在 0 和 1 间的实数(包括0,1),一条从u 到 v 的通道P 的安全度为Safe(P) = s(e1)*s(e2)…*s(ek) e1,e2,ek是P 上的边 ,现在8600 想出去旅游,面对这这么多的路,他想找一条最安全的路。但是8600 的数学不好,想请你帮忙 ^_^
Input 输入包括多个测试实例,每个实例包括:
第一行:n。n表示城市的个数n<=1000;
接着是一个n*n的矩阵表示两个城市之间的安全系数,(0可以理解为那两个城市之间没有直接的通道)
接着是Q个8600要旅游的路线,每行有两个数字,表示8600所在的城市和要去的城市
Output 如果86无法达到他的目的地,输出”What a pity!”,
其他的输出这两个城市之间的最安全道路的安全系数,保留三位小数。
Sample Input
3 1 0.5 0.5 0.5 1 0.4 0.5 0.4 1 3 1 2 2 3 1 3
Sample Output
0.500 0.400 0.500
一开始看,这道确实挺水,但是没想到被坑了这么久。。。。
伤心的事情就不多说了,这道题我们只要着重注意下0的地方就可了
#include <stdio.h>
#include <string.h>
#include <math.h>
#include <algorithm>
using namespace std;
const double inf = 1000000;
int n,m;
double map[1005][1005],cast[1005];
int x,y,vis[1005];
void Dijkstra(int s,int e)
{
int i,j,pos;
double maxn;
int flag = 0;
for(i = 1; i<=n; i++)
{
vis[i] = 0;
cast[i] = map[s][i];
}
vis[s] = 1;
for(i = 1; i<n; i++)
{
pos = s;
maxn = 0;
for(j = 1; j<=n; j++)
{
if(cast[j]>maxn && !vis[j])
{
pos = j;
maxn = cast[j];
}
}
if(fabs(maxn)<=10e-6)
{
flag = 1;
break;
}
vis[pos] = 1;
for(j = 1; j<=n; j++)
{
if(!vis[j] && map[pos][j]>0 && cast[pos]*map[pos][j]>cast[j])
cast[j] = cast[pos]*map[pos][j];
}
}
if(flag)
printf("What a pity!\n");
else
printf("%.3lf\n",cast[e]);
}
int main()
{
int i,j;
double w;
while(~scanf("%d",&n))
{
for(i = 1; i<=n; i++)
for(j = 1; j<=n; j++)
scanf("%lf",&map[i][j]);
scanf("%d",&m);
while(m--)
{
scanf("%d%d",&x,&y);
Dijkstra(x,y);
}
}
return 0;
}