HDU1546:Idiomatic Phrases Game(Dijkstra)

Problem Description Tom is playing a game called Idiomatic Phrases Game. An idiom consists of several Chinese characters and has a certain meaning. This game will give Tom two idioms. He should build a list of idioms and the list starts and ends with the two given idioms. For every two adjacent idioms, the last Chinese character of the former idiom should be the same as the first character of the latter one. For each time, Tom has a dictionary that he must pick idioms from and each idiom in the dictionary has a value indicates how long Tom will take to find the next proper idiom in the final list. Now you are asked to write a program to compute the shortest time Tom will take by giving you the idiom dictionary.
 

 

Input The input consists of several test cases. Each test case contains an idiom dictionary. The dictionary is started by an integer N (0 < N < 1000) in one line. The following is N lines. Each line contains an integer T (the time Tom will take to work out) and an idiom. One idiom consists of several Chinese characters (at least 3) and one Chinese character consists of four hex digit (i.e., 0 to 9 and A to F). Note that the first and last idioms in the dictionary are the source and target idioms in the game. The input ends up with a case that N = 0. Do not process this case.
 

 

Output One line for each case. Output an integer indicating the shortest time Tome will take. If the list can not be built, please output -1.  

Sample Input

5 5 12345978ABCD2341 5 23415608ACBD3412 7 34125678AEFD4123 15 23415673ACC34123 4 41235673FBCD2156 2 20 12345678ABCD 30 DCBF5432167D 0  

Sample Output

17 -1

 

 

题意:成语接龙的游戏,一个中文字是四个字符组成,所以只要一个字符串后四个字符与另一个字符串的头四个字符能匹配,那么就能接上,求出从第一个成语开始能不能到最后一个,能则处处最少时间

 

 

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
const int inf = 1000000000;
int n;
int val[1005];
int map[1005][1005];
char str[1005][1005];
int vis[1005],cast[1005];

void Dijkstra(int s)
{
    int i,j,min,pos;
    memset(vis,0,sizeof(vis));
    for(i = 0; i<n; i++)
        cast[i] = map[s][i];
    cast[s] = 0;
    vis[s] = 1;
    for(i = 1; i<n; i++)
    {
        min = inf;
        for(j = 0; j<n; j++)
        {
            if(cast[j]<min && !vis[j])
            {
                pos = j;
                min = cast[j];
            }
        }
        vis[pos] = 1;
        for(j = 0; j<n; j++)
        {
            if(cast[pos]+map[pos][j]<cast[j] && !vis[j])
                cast[j] = cast[pos]+map[pos][j];
        }
    }
}

int main()
{
    int i,j,len;
    while(~scanf("%d",&n) && n)
    {
        for(i = 0; i<n; i++)
            scanf("%d%s",&val[i],str[i]);
        for(i = 0; i<n; i++)
        {
            for(j = 0; j<n; j++)
            {
                len = strlen(str[i]);
                if(str[j][0] == str[i][len-4] && str[j][1] == str[i][len-3] &&str[j][2] == str[i][len-2]&&str[j][3] == str[i][len-1])
                    map[i][j] = val[i];
                else
                    map[i][j] = inf;
            }
        }
        Dijkstra(0);
        if(n==1)
        printf("-1\n");
        else
        printf("%d\n",cast[n-1]==inf?-1:cast[n-1]);
    }

    return 0;
}

    原文作者:Dijkstra算法
    原文地址: https://blog.csdn.net/libin56842/article/details/17102217
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞