Til the Cows Come Home ( POJ 2387) (简单最短路 Dijkstra)

problem

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible.

Farmer John’s field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it.

Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N

* Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

90

Hint

INPUT DETAILS:

There are five landmarks.

OUTPUT DETAILS:

Bessie can get home by following trails 4, 3, 2, and 1.

 题解:简单的最短路,板子题,一遍Dijkstra。

#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
using namespace std;
int m,n;
const int inf = 0x3f3f3f3f;
int dis[1005];
int gra[1005][1005];
int vis[1005];
void dj()
{
    memset(vis,0,sizeof(vis));
    int minn,v;
    for(int i = 1; i <= n; i ++) dis[i] = gra[1][i];
    for(int i = 1; i <= n; i ++)
    {
        minn = inf;
        for(int j = 1; j <= n; j ++)
        {
            if(!vis[j] && dis[j] < minn)
            {
                minn = dis[j];
                v = j;
            }
        }
        vis[v] = 1;
        for(int j = 1; j <= n; j ++)
        {
            if(gra[v][j] + dis[v] < dis[j] && !vis[j])
            {
                dis[j] = gra[v][j] + dis[v];
            }
        }
    }
    printf("%d\n",dis[n]);
}
int main()
{
    int i,j,a,b,c;
    while(~scanf("%d%d",&m,&n))
    {
        for(i = 1; i <= n; i ++)
        {
            for(j = 1; j <= n; j ++)
            {
                if(i == j) gra[i][j] = 0;
                else gra[i][j] = gra[j][i] = inf;
            }
        }
        for(i = 1; i <= m; i ++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(gra[a][b] > c ) gra[a][b] = gra[b][a] = c;
        }
        dj();
    }
    return 0;
}

 

    原文作者:Dijkstra算法
    原文地址: https://blog.csdn.net/Mercury_Lc/article/details/83175821
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞