poj3268(dijkstra算法变形)

D – Silver Cow Party

 

One cow from each of N farms (1 ≤ N ≤ 1000) conveniently numbered 1..N is going to attend the big cow party to be held at farm #X (1 ≤ X ≤ N). A total of M (1 ≤ M ≤ 100,000) unidirectional (one-way roads connects pairs of farms; road i requires Ti (1 ≤ Ti ≤ 100) units of time to traverse.

Each cow must walk to the party and, when the party is over, return to her farm. Each cow is lazy and thus picks an optimal route with the shortest time. A cow’s return route might be different from her original route to the party since roads are one-way.

Of all the cows, what is the longest amount of time a cow must spend walking to the party and back?

Input Line 1: Three space-separated integers, respectively: 
N
M, and 
X 

Lines 2.. 
M+1: Line 
i+1 describes road 
i with three space-separated integers:
Ai
Bi, and 
Ti. The described road runs from farm 
Ai to farm 
Bi, requiring 
Titime units to traverse. Output Line 1: One integer: the maximum of time any one cow must walk. Sample Input

4 8 2
1 2 4
1 3 2
1 4 7
2 1 1
2 3 5
3 1 2
3 4 4
4 2 3

Sample Output

10

Hint Cow 4 proceeds directly to the party (3 units) and returns via farms 1 and 3 (7 units), for a total of 10 time units.

        好题,有向图,1——n个点 输入其中一个点x,求x点到其他点的距离和其他点到x的距离之和最短 ,一开始果断用了floyd结果超时了尝试了两次迪杰斯特拉,。。。结果居然过了不明觉厉,先用迪杰斯特拉求出x到其他所有点的距离之和,再把map[i][j]和map[j][i]swap一下就变成了从其他点到x了。很经典的迪杰斯特拉变形。贴上代码:

         

#include<iostream>
#include<stdio.h>
#include<string.h>
using namespace std;
const int inf=999999;
int dis[1055];
int vis[1055];
int mp[1055][1555];
int n,m;
int arr[1055]={0};
void dijkstra(int bg,int en){
	memset(vis,0,sizeof(vis));
	for(int i=1;i<=n;i++) dis[i]=mp[bg][i];
	int minn,pos;
	for(int i=1;i<=n;i++){
	    minn=inf;
	    for(int j=1;j<=n;j++){
	    	if(!vis[j]&&dis[j]<minn){
	    		pos=j;
	    		minn=dis[j];
			}
		}
		vis[pos]=1;
		for(int j=1;j<=n;j++){
		 if(!vis[j]) dis[j]=min(dis[j],dis[pos]+mp[pos][j]);
		}
	}
	for(int i=1;i<=n;i++){
	
		   		arr[i]+=dis[i];
	}
} 
int main(){
           int x;
		scanf("%d%d%d",&n,&m,&x);
		for(int i=1;i<=n;i++)
		    for(int j=1;j<=n;j++){
		    if(i==j) mp[i][j]=0;
		    else mp[i][j]=inf;
		}
		    memset(arr,0,sizeof(arr));
		   int a,b,c;
		   while(m--){
		   	scanf("%d%d%d",&a,&b,&c);
		   	 mp[a][b]=c;
		   }
		   dijkstra(x,n);
		   for(int i=1;i<n;i++)
		       for(int j=i+1;j<=n;j++) swap(mp[i][j],mp[j][i]);
		       dijkstra(x,n);
		       int sum=0;
		   for(int i=1;i<=n;i++)  sum=max(sum,arr[i]);
		   cout<<sum<<endl; 
}

    原文作者:Dijkstra算法
    原文地址: https://blog.csdn.net/xxxslinyue/article/details/63800655
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞