动态规划【Longest Ordered Subsequence】

Description

A numeric sequence of 
ai is ordered if 
a1 < 
a2 < … < 
aN. Let the subsequence of the given numeric sequence (
a1
a2, …, 
aN) be any sequence (
ai1
ai2, …, 
aiK), where 1 <= 
i1 < 
i2 < … < 
iK <= 
N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.

Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence – N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000

Output

Output file must contain a single integer – the length of the longest ordered subsequence of the given sequence.

Sample Input

7
1 7 3 5 9 4 8

Sample Output

4

最长不下降子序列

示例分析:

1 7 3 5 9 4 8

1 2 2 3 4 3 4

#include <stdio.h>
#include <algorithm>
#include <string.h>
using namespace std;
int a[1005],dp[1005],n;
int LIS()
{
    int i,j,ans,m;
    dp[1] = 1;
    ans = 1;
    for(i = 2;i<=n;i++)
    {
        m = 0;
        for(j = 1;j<i;j++)
        {
            if(dp[j]>m && a[j]<a[i])        
            m = dp[j];
        }
        dp[i] = m+1;                      
        if(dp[i]>ans)
        ans = dp[i];
    }
    return ans;
}

int main()
{
    int i;
    while(~scanf("%d",&n))
    {
        for(i = 1;i<=n;i++)
        scanf("%d",&a[i]);
        printf("%d\n",LIS());

    }

    return 0;
}
    原文作者:动态规划
    原文地址: https://blog.csdn.net/castledrv/article/details/24495539
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞