A - Max Sum Plus Plus HDU1024 ( 动态规划 多段连续子段和的最大值)

A – Max Sum Plus Plus

Time Limit:1000MS Memory Limit:32768KB 64bit IO Format:%I64d & %I64u

Submit Status

Description

Now I think you have got an AC in Ignatius.L’s “Max Sum” problem. To be a brave ACMer, we always challenge ourselves to more difficult problems. Now you are faced with a more difficult problem.

Given a consecutive number sequence S 1, S 2, S 3, S 4 … S x, … S n (1 ≤ x ≤ n ≤ 1,000,000, -32768 ≤ S x ≤ 32767). We define a function sum(i, j) = S i + … + S j (1 ≤ i ≤ j ≤ n).

Now given an integer m (m > 0), your task is to find m pairs of i and j which make sum(i 1, j 1) + sum(i 2, j 2) + sum(i 3, j 3) + … + sum(i m, j m) maximal (i x ≤ i y ≤ j x or i x ≤ j y ≤ j x is not allowed).

But I`m lazy, I don’t want to write a special-judge module, so you don’t have to output m pairs of i and j, just output the maximal summation of sum(i x, j x)(1 ≤ x ≤ m) instead. ^_^

Input

Each test case will begin with two integers m and n, followed by n integers S 1, S 2, S 3 … S n.

Process to the end of file.

Output

Output the maximal summation described above in one line.

Sample Input

1 3 1 2 3 2 6 -1 4 -2 3 -2 3

Sample Output

6 8 

题意:求n个元素数组的m段连续子段和的最大值

dp[i][j]=前j个数选择i段的最大值

状态转移:dp[i][j]=max(dp[i][j-1]  ,  max{dp[i-1][k]}  )+a[j]  (i-1<=k<=j-1)

第J个元素可以和前面的连接在一起,构成i段,或者独自成为一段,

如果是独自成为一段的话,那么前j-1个数必须组合出i-1段,选择多种情况里的最大值,

最后由于数据较大,所以要压缩空间,使用滚动数组


#include<cstdio>
#include<algorithm>
#include<cmath>
#include<cstdlib>
#include<cstring>
#include<vector>
using namespace std;
const int maxn=1000005;
typedef __int64 LL;

int a[maxn],dp[maxn];
int pre[maxn];//对应递推式的第二项
int main(){
    int T;
    //freopen("Text//in.txt","r",stdin);
    int n,m;
    while(~scanf("%d%d",&m,&n)){
        for(int i=1;i<=n;i++){
            scanf("%d",a+i);
            dp[i]=pre[i]=0;
        }
        int mx;
        dp[0]=pre[0]=0;
        for(int i=1;i<=m;i++){
            mx=-999999999;
            for(int j=i;j<=n;j++){
                dp[j]=max(dp[j-1],pre[j-1])+a[j];
                pre[j-1]=mx;
                mx=max(dp[j],mx);
            }
        }
        printf("%d\n",mx);
    }
    return 0;
}







    原文作者:动态规划
    原文地址: https://blog.csdn.net/u013167299/article/details/44703807
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞