XYNUOJ 1246 Repair the Wall —贪心算法

欢迎访问XYNUOJ

1246: Repair the Wall

时间限制: 1 Sec  
内存限制: 32 MB

提交: 27  
解决: 14

[
提交][
状态][
讨论版][
Edit] [
TestData]

题目描述

Long time ago , Kitty lived in a small village. The air was fresh and the scenery was very beautiful. The only thing that troubled her is the typhoon.
When the typhoon came, everything is terrible. It kept blowing and raining for a long time. And what made the situation worse was that all of Kitty’s walls were made of wood.
One day, Kitty found that there was a crack in the wall. The shape of the crack is 
a rectangle with the size of 1×L (in inch). Luckly Kitty got N blocks and a saw(锯子) from her neighbors.
The shape of the blocks were rectangle too, and the width of all blocks were 1 inch. So, with the help of saw, Kitty could cut down some of the blocks(of course she could use it directly without cutting) and put them in the crack, and the wall may be repaired perfectly, without any gap.
Now, Kitty knew the size of each blocks, and wanted to use as fewer as possible of the blocks to repair the wall, could you help her ?

输入

The problem contains many test cases, please process to the end of file( EOF ).
Each test case contains two lines.
In the first line, there are two integers L(0<L<1000000000) and N(0<=N<600) which
mentioned above.
In the second line, there are N positive integers. The ith integer Ai(0<Ai<1000000000 ) means that the ith block has the size of 1×Ai (in inch).

输出

For each test case , print an integer which represents the minimal number of blocks are needed.
If Kitty could not repair the wall, just print “impossible” instead.

样例输入

2 2 12 11 14 3 27 11 4 109 5 38 15 6 21 32 5 3 1 1 1

样例输出

1
1 5 impossible
/*
**类型:贪心算法
**题目来源:NYOJ
**时间:2017/7/29
**问题描述:有缺口和木块的宽是一样的,给出多个木块的长,使用尽可能少的木块修复缺口 
**输入:第一行 L 缺口长度  N 木块个数 第二行 N个木块的长度 
**输出:最少使用的木块个数 / impossible
**解决方案:贪心算法:木块长从大到小排序,依次使用 
*/
#include<stdio.h>
#include<algorithm>
using namespace std;

//从大到小排序 
int cmp(int a,int b)
{
	return a > b;
}

int main()
{
	int L, N;  //缺口长度  N个木块 
	while(scanf("%d%d",&L,&N)!=EOF)
	{
		int a[610];
		//输入木块长 
		for(int i = 0; i < N; i++)
		{
			scanf("%d",&a[i]);
		}
		//排序 
		sort(a,a+N,cmp);
		//初始化 计数器 
		int sum = 0, count = 0;
		for(int i = 0; i < N; i++)
		{
			sum = sum + a[i];
			count++;
			if(sum >= L)    
			{
				printf("%d\n",count);
				break;
			}
		}
		//不能修复 
		if(sum < L)
		{
			printf("impossible\n");
		}
	} 
	return 0;
}
    原文作者:贪心算法
    原文地址: https://blog.csdn.net/liujiuxiaoshitou/article/details/76468132
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞