ACM 贪心算法

这是大学期间ACM校赛时我出的一道题,考贪心算法,没有牵涉复杂的数据结构,有题目加源代码。

赢取最多最有价值的礼物

Problem Description 

五一期间到长沙烈士公园玩,走进去之后,发现许多人在围在一起玩一种游戏,游戏规则是:给你M个环,用一个环可以套住一个礼物,同时抛出时要花费一秒钟的时间,礼物的价值各不相同,小到一个打火机,大到一个漂亮的布娃娃,其中有一个规定,就是每一件礼物必须在规定的时间内被你套中,否则套中了也无效。你当然想在规定的时间内套中一些有较高价值的礼物,假设你每次都能套中,现在请你算出你能赢取的最大礼物价值量。

 

Input

第一行输入一个整数N,表示要测试的组数,然后每组测试占三行,第一行输入一个整数M(0<M<1000),表示你手里一共有M个环。第二行输入M个整数,表示每件礼物的价值量。第三输入M个整数,表示每件礼物必须在这个时间(单位为秒)被套中才能生效。 。

 

Output

每组测试数据占一行,输出最大的礼物价值量。 

 

Sample Input

3

3

3 33

10 51

3

1 3 1

6 2 3

7

1 4 6 4 2 4 3

3 2 1 7 6 5 4

 

 

Sample Output

16

8

23

/*贪心算法*/

#include<stdio.h>
#include<string.h>
#define max 1005
struct he
{
int time;
int score;
};
bool flag[max];
int main()
{
he present[max],temp;
int i,j;
int n,m,count;
scanf(“%d”,&n);
while(n–)
{
count=0;
scanf(“%d”,&m);
for(i=0;i<m;i++)
scanf(“%d”,&present[i].time);
for(i=0;i<m;i++)
scanf(“%d”,&present[i].score);
for(i=0;i<max;i++)
flag[i]=false;
// memset(flag,0,sizeof(flag));
for(i=0;i<m;i++)
for(j=i+1;j<m;j++)
{
if(present[j].score>present[i].score)
{  temp=present[j];present[j]=present[i];present[i]=temp;}
else if(present[j].score==present[i].score && present[j].time<present[i].time)
{temp=present[j];present[j]=present[i];present[i]=temp;}
}
for(i=0;i<m;i++)
{
for(j=present[i].time;j>0;j–)
{
if(flag[j]==false)
{
flag[j]=true;
break;
}
}
if(j!=0)
count+=present[i].score;
}
printf(“%d\n”,count);
}
return 0;
}

    原文作者:贪心算法
    原文地址: https://blog.csdn.net/qq943574281/article/details/39999673
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞