acm之贪心算法题目10

Problem Description

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

Input

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.

Output

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

Sample Input

5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1

Sample Output

13.333
31.500

代码:

#include<stdio.h>
#include<stdlib.h>
#include<algorithm>
using namespace std;

#define Max 1000

struct room{
    double j,f;
    double rate;
}Room[Max];

bool cmp(room a,room b)
{
    return a.rate>b.rate;
}


int main()
{
    int N; 
    double M,sumJ;
    int i;
    while(scanf("%lf %d",&M,&N))
    {
        if(M==-1&&N==-1)
            break;
        for(i=0;i<N;i++)
        {
            scanf("%lf%lf",&Room[i].j,&Room[i].f);
            Room[i].rate=(double)Room[i].j/Room[i].f;
        }
        sort(Room,Room+N,cmp); 
        sumJ=0;
        for(i=0;i<N;i++)
        {
            if(M>=Room[i].f)
            {
                sumJ+=Room[i].j;
                M-=Room[i].f;
            }
            else
            {
                sumJ+=(Room[i].rate)*M;
                break;
            }
        }
        printf("%.3lf\n",sumJ);
    }
    return 0;
}
    原文作者:贪心算法
    原文地址: https://blog.csdn.net/shelly1072/article/details/51761683
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞