题目描述:
FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.
输入:
The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1’s. All integers are not greater than 1000.
输出:
For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.
样例输入:
5 3
7 2
4 3
5 2
20 3
25 18
24 15
15 10
-1 -1
样例输出:
13.333
31.500
题目的意思是:有m元钱,有n种物品,每种物品有J磅,总价值f元,可以使用0到f的任意价格购买相应磅的物品。要求输出用m元钱最多能买到多少磅的物品。
输入第一行是两个数字m和n,分别代表有m元和n种物品,接下来n行分被代表每种物品的重量和价值。输入m和n为-1时程序结束。
输出为买到物品的重量。
思路:这个题就是典型的贪心算法,现在再看这个算法,其实的确十分厉害。后悔当初没有好好学习。
思路就是每次都购买剩下物品种性价比最高的物品,直到物品被买完或者钱用光了。
代码如下:
#include <iostream>
#include<algorithm>
#include<string.h>
#include<stdio.h>
using namespace std;
struct goods
{
double j; // 重量
double f; // 价值
double s; // 性价比
bool operator < (const goods &A) const
{
return s > A.s;
}
}buf[1000];
int main()
{
double m;
int n;
int i;
while(scanf("%lf%d", &m, &n)!=EOF)
{
if(m==-1 && n==-1 ) break;
for(i=0; i<n; i++)
{
scanf("%lf %lf", &buf[i].j, &buf[i].f);
buf[i].s = buf[i].j / buf[i].f;
}
sort(buf, buf+n);
int idx=0; //当前货物下标
double ans = 0; //总重量
while(m>0 && idx<n) //循环条件是既有物品剩余还有钱剩余
{
if(m>buf[idx].f)
{
ans += buf[idx].j;
m -= buf[idx].f;
}
else
{
ans += buf[idx].j * m / buf[idx].f; //要理解这一步的含义
m=0;
}
idx ++;
}
printf("%.3lf\n", ans);
}
return 0;
}