Ordering Tasks
Input: standard input
Output: standard output
Time Limit: 1 second
Memory Limit: 32 MB
John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 <= n <= 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4
1 2
2 3
1 3
1 5
0 0
Sample Output
1 4 2 5 3
题目大意:给出n组数据,前面的的序号表示这个任务先于后面序号的任务,要求将任务先后排序(不一定有一种)
解题思路:拓扑排序,先将数据存成有向图,遍历,输出入读为0的点,并且将该点所有出入抹掉。再遍历,知道所有点都已经输出。
#include<stdio.h>
#include<string.h>
#define N 105
int m, n, cnt;
int map[N][N], bo[N];
int judge(int k){
for (int i = 1; i <= n; i++)
if (map[k][i])
return 0;
return 1;
}
int clear(int k){
for (int i = 1; i <= n; i++)
map[i][k] = 0;
}
int main(){
while (scanf("%d%d", &n, &m), n || m){
// Init.
memset(map, 0, sizeof(map));
memset(bo, 0, sizeof(bo));
cnt = 0;
// Read.
for (int i = 0; i < m; i++){
int a, b;
scanf("%d%d", &a, &b);
map[b][a] = 1;
}
// Handle.
while (cnt < n){
for (int i = 1; i <= n; i++){
if (bo[i]) continue;
if (judge(i)){
if (cnt)
printf(" ");
printf("%d", i);
bo[i] = 1;
cnt++;
clear(i);
break;
}
}
}
printf("\n");
}
return 0;}