UVA - 10305 Ordering Tasks(拓扑排序)

John has n tasks to do. Unfortunately, the tasks are not independent and the execution of one task is only possible if other tasks have already been executed.
Input
The input will consist of several instances of the problem. Each instance begins with a line containing two integers, 1 ≤ n ≤ 100 and m. n is the number of tasks (numbered from 1 to n) and m is the number of direct precedence relations between tasks. After this, there will be m lines with two integers i and j, representing the fact that task i must be executed before task j. An instance with n = m = 0 will finish the input.
Output
For each instance, print a line with n integers representing the tasks in a possible order of execution.
Sample Input
5 4 1 2 2 3 1 3 1 5 0 0
Sample Output
1 4 2 5 3
对于拓扑排序,可以把他们的小于看成一条有向边,然后递归遍历。如果我们能找到环则不存在拓扑排序。借助于dfs,在访问完一个节点后可以把它加到当前排序好的首部。

AC

#include <algorithm>

#include <string>

#include <iostream>

#include <string.h>

#include<stdio.h>

#include<vector>

using namespace std;

#define maxn 1000

#define ll  long long int

int vis[maxn],topo[maxn],pos,n,m,G[maxn][maxn];

bool dfs(int u)

{

    vis[u]=-1;

    for(int v=1;v<=n;v++)

    {

        if(G[u][v])

        {

            if(vis[v]==-1) return false;

            else if(!vis[v]&&!dfs(v)) return false;

        }

    }

    vis[u]=1;

    topo[pos–]=u;

    return 1;

}

bool toposort()

{

    pos=n;

    memset(vis,0,sizeof(vis));

    for(int u=1;u<=n;u++)

    {

        if(!vis[u])

        {

            if(!dfs(u)) return false;

        }

    }

     return true;

}

int main()

{

    while(scanf(“%d%d”,&n,&m)==2&&n)

    {

        int st,ed;

        pos=n;

        memset(G,0,sizeof(G));

        memset(vis,0,sizeof(vis));

        for(int i=0;i<m;i++)

        {

            scanf(“%d%d”,&st,&ed);

            G[st][ed]=1;

        }

         toposort();

         for(int i=pos+1;i<=n;i++)

         {

             if(i!=pos+1) printf(” “);

             printf(“%d”,topo[i]);

         }

         printf(“\n”);

    }

    return 0;

}

    原文作者:拓扑排序
    原文地址: https://blog.csdn.net/longshanxiaoxuesheng/article/details/51008842
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞