HDU3342-拓扑排序

Legal or Not

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7925    Accepted Submission(s): 3748

Problem Description ACM-DIY is a large QQ group where many excellent acmers get together. It is so harmonious that just like a big family. Every day,many “holy cows” like HH, hh, AC, ZT, lcc, BF, Qinz and so on chat on-line to exchange their ideas. When someone has questions, many warm-hearted cows like Lost will come to help. Then the one being helped will call Lost “master”, and Lost will have a nice “prentice”. By and by, there are many pairs of “master and prentice”. But then problem occurs: there are too many masters and too many prentices, how can we know whether it is legal or not?

We all know a master can have many prentices and a prentice may have a lot of masters too, it’s legal. Nevertheless,some cows are not so honest, they hold illegal relationship. Take HH and 3xian for instant, HH is 3xian’s master and, at the same time, 3xian is HH’s master,which is quite illegal! To avoid this,please help us to judge whether their relationship is legal or not. 

Please note that the “master and prentice” relation is transitive. It means that if A is B’s master ans B is C’s master, then A is C’s master.  

Input The input consists of several test cases. For each case, the first line contains two integers, N (members to be tested) and M (relationships to be tested)(2 <= N, M <= 100). Then M lines follow, each contains a pair of (x, y) which means x is y’s master and y is x’s prentice. The input is terminated by N = 0.

TO MAKE IT SIMPLE, we give every one a number (0, 1, 2,…, N-1). We use their numbers instead of their names.  

Output For each test case, print in one line the judgement of the messy relationship.

If it is legal, output “YES”, otherwise “NO”.  

Sample Input

3 2 0 1 1 2 2 2 0 1 1 0 0 0  

Sample Output

YES NO  

题目大意:

                   给你n个人和m组关系,关系表示为 a b 表示a是b的主人 ,每个人可能有多个主人也可能有多个下属问你m个关系是否存在矛盾


题目思路:

                直接拓扑排序判断是否有矛盾,拓扑排序为先从入度为0的点查询如果子节点入度为1然后入队列,子节点入度减一,如果最后访问到的点数为n则说明不存在矛盾否则存在


AC代码:

#include<cstring>
#include<cstdio>
#include<queue>
#include<vector>
using std::queue;
using std::vector;
const int maxn = 1e2+10;

int cnt[maxn];
vector<int>edge[maxn];
int n,m;


void topsort(){     //拓扑排序
    queue<int>q;
    for(int i=0;i<n;i++){
        if(cnt[i]==0)q.push(i);   //首先从入度为0的点开始
    }
    int num = 0;
    while(!q.empty()){
        int u = q.front();
        q.pop();
        num++;
        int len = edge[u].size();
        for(int i=0;i<len;i++){
            int v = edge[u][i];
            if(cnt[v]==1)q.push(v);    //子节点入度为1的入队
            cnt[v]--;
        }
    }
    if(num==n)puts("YES");   //访问的点数==n
    else puts("NO");
}
int main()
{
    while(~scanf("%d%d",&n,&m),n+m){
        memset(cnt,0,sizeof(cnt));
        memset(edge,0,sizeof(edge));
        while(m--){
            int u,v;scanf("%d%d",&u,&v);
            edge[u].push_back(v);   //建图
            cnt[v]++;              //记录点的度数
        }
        topsort();
    }

    return 0;
}


    原文作者:拓扑排序
    原文地址: https://blog.csdn.net/qq_34731703/article/details/60160176
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞