hdoj 2647 Reward(拓扑排序+队列)

Reward

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9919    Accepted Submission(s): 3166

Problem Description Dandelion’s uncle is a boss of a factory. As the spring festival is coming , he wants to distribute rewards to his workers. Now he has a trouble about how to distribute the rewards.

The workers will compare their rewards ,and some one may have demands of the distributing of rewards ,just like a’s reward should more than b’s.Dandelion’s unclue wants to fulfill all the demands, of course ,he wants to use the least money.Every work’s reward will be at least 888 , because it’s a lucky number.  

Input One line with two integers n and m ,stands for the number of works and the number of demands .(n<=10000,m<=20000)

then m lines ,each line contains two integers a and b ,stands for a’s reward should be more than b’s.  

Output For every case ,print the least money dandelion ‘s uncle needs to distribute .If it’s impossible to fulfill all the works’ demands ,print -1.  

Sample Input

2 1 1 2 2 2 1 2 2 1  

Sample Output

1777 -1  

Author dandelion  

Source
曾是惊鸿照影来  

Recommend

yifenfei   |   We have carefully selected several similar problems for you:  1285 3342 1811 2680 2112 

注意:逆序建立边,每去掉一个节点,与之相连的边价值+1

#include <iostream>
#include <string>
#include<cstring>
#include <cstdio>
#include<algorithm>
#include<vector>
#include<queue>
const int MAXN = 100010;
using namespace std;

vector<int>graph[MAXN];
int indegree[MAXN];
int  n,m,cnt,k;
int sum;


bool toposort()
{
	queue<int>q;
	int v[MAXN];
	
	k = 0;
	cnt = 0;
	for (int i = 1; i <= n; i++)
	{
		if (indegree[i] == 0) {
			q.push(i);
			cnt++;
			v[i] = 888;
		}
	}
	if (!cnt)return false;//有环
	while (!q.empty())
	{
		int temp = q.front();
		q.pop();
		k++;
		sum += v[temp];
		for (int i = 0; i < graph[temp].size(); i++)
		{
			indegree[graph[temp][i]]--;
			if (indegree[graph[temp][i]] == 0)
			{
				q.push(graph[temp][i]);
			}
			v[graph[temp][i]] = v[temp] + 1;//所有相连的点+1
		}
	}
	if (k < n)return false;//有环
	return true;
} 
int main()
{
	
	while (scanf("%d%d", &n, &m) != EOF)
	{
		cnt = 0;
		sum = 0;
		for (int i = 0; i <= n; i++)
			graph[i].clear();
		memset(indegree, 0, sizeof(indegree));
		int a, b;
		for (int i = 0; i < m; i++) 
		{
			scanf("%d%d", &b, &a);
			graph[a].push_back(b);
			indegree[b]++;
		}
		if (toposort()) { printf("%d\n",sum); }
		else printf("-1\n");
	}
	return 0;
}

    原文作者:拓扑排序
    原文地址: https://blog.csdn.net/qq3434569/article/details/77926364
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞