HDU 1285 拓扑排序+优先队列

确定比赛名次

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23835    Accepted Submission(s): 9617

Problem Description 有N个比赛队(1<=N<=500),编号依次为1,2,3,。。。。,N进行比赛,比赛结束后,裁判委员会要将所有参赛队伍从前往后依次排名,但现在裁判委员会不能直接获得每个队的比赛成绩,只知道每场比赛的结果,即P1赢P2,用P1,P2表示,排名时P1在P2之前。现在请你编程序确定排名。

 

Input 输入有若干组,每组中的第一行为二个数N(1<=N<=500),M;其中N表示队伍的个数,M表示接着有M行的输入数据。接下来的M行数据中,每行也有两个整数P1,P2表示即P1队赢了P2队。

 

Output 给出一个符合要求的排名。输出时队伍号之间有空格,最后一名后面没有空格。

其他说明:符合条件的排名可能不是唯一的,此时要求输出时编号小的队伍在前;输入数据保证是正确的,即输入数据确保一定能有一个符合要求的排名。

 

Sample Input

4 3 1 2 2 3 4 3  

Sample Output

1 2 4 3  

Author SmallBeer(CML)  

Source
杭电ACM集训队训练赛(VII)  

拓扑排序的裸题,为了保证序号小的在前,再加个优先队列即可。

#include <bits/stdc++.h>
using namespace std;

const int maxn = 550;
vector<int> G[maxn];
int deepth[maxn],n;

void topsort(){
	priority_queue<int, vector<int>, greater<int> > que;
	int i,cnt = 0;
	for(i=1 ;i<=n ;i++){
		if(!deepth[i]){
			que.push(i);
			deepth[i] = -1;
		}
	}
	while(que.size()){
		int t = que.top();
		que.pop();
		for(i=0 ;i<G[t].size() ;i++){
			deepth[G[t][i]]--;
			if(!deepth[G[t][i]]){
				que.push(G[t][i]);
			}
		}
		if(cnt)
			printf(" ");
		printf("%d",t);
		cnt++;
	}
}

int main(){
	int m;
	while(scanf("%d%d",&n,&m) != EOF){
		int i,x,y;
		for(i=1 ;i<=n ;i++){
			G[i].clear();
		}
		memset(deepth,0,sizeof(deepth));
		for(i=0 ;i<m ;i++){
			scanf("%d%d",&x,&y);
			G[x].push_back(y);
			deepth[y]++;
		}	
		topsort();
		printf("\n");
	}
	return 0;
}

 

    原文作者:拓扑排序
    原文地址: https://blog.csdn.net/wubaizhe/article/details/54645069
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞