HDOJ-1003: 最大连续和

HDOJ-1003题目如下
Problem Description
Given a sequence a[1],a[2],a[3]……a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).

Output
For each test case, you should output two lines. The first line is “Case #:”, # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.

Sample Input
2
5 6 -1 5 4 -7
7 0 6 -1 1 -6 7 -5

Sample Output
Case 1:
14 1 4

Case 2:
7 1 6

简单翻译一下就是,给定一个数组,在里面找一个连续的子数组,使其和最大,并输出这个最大值,以及这个区间的左右索引号。(这个输出格式真的是烦人)
总体思路就是累加求和,如果当前值大于所设定的最大值,那么就交换。并记录此时的左右索引,否则继续累加。如果此时和小于0,那么直接舍弃掉。

#include <iostream>
#include <algorithm>
using namespace std;
int a[100001];
int main(){
    int number;
    cin >> number;

    for(int i = 1; i <= number; i++){
        int max = INT_MIN;
        int t,left, right;
        cin >> t;
        left = right = 1;
        int m = 1;
        int sum = 0;
        for(int j = 1; j <= t; j++){
            cin >> a[i];
            sum += a[i];
            if(sum > max){
                max = sum;
                right = j;
                left = m;
            }
            if(sum < 0){
                sum = 0;
                m = j + 1;
            }
        }
        cout << "Case " << i << ":" << endl;
        cout << max << " "<< left << " " << right << endl;
        if( i < number )
            cout << endl;
    }
    system("pause");
    return 0;
}
    原文作者:wilder_ting
    原文地址: https://segmentfault.com/a/1190000020376492
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞