数据结构实验之图论二:基于邻接表的广度优先搜索遍历
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
给定一个无向连通图,顶点编号从0到n-1,用广度优先搜索(BFS)遍历,输出从某个顶点出发的遍历序列。(同一个结点的同层邻接点,节点编号小的优先遍历)
Input
输入第一行为整数n(0< n <100),表示数据的组数。
对于每组数据,第一行是三个整数k,m,t(0<k<100,0<m<(k-1)*k/2,0< t<k),表示有m条边,k个顶点,t为遍历的起始顶点。
下面的m行,每行是空格隔开的两个整数u,v,表示一条连接u,v顶点的无向边。
Output
输出有n行,对应n组输出,每行为用空格隔开的k个整数,对应一组数据,表示BFS的遍历结果。
Sample Input
1
6 7 0
0 3
0 4
1 4
1 5
2 3
2 4
3 5
Sample Output
0 3 4 2 5 1
Hint
用邻接表存储。
Source
#include<stdio.h>
#include<stdlib.h>
#include<string.h>
#include<queue>
using namespace std;
int book[101];
struct node
{
int data;
struct node*next;
}*head[1001];
void arrange(int n)
{
for(int i=0; i<n; i++)
{
struct node*p,*q;
for(p=head[i]->next; p; p=p->next)//排序的时候从头结点之后的点开始,不能包含头结点
{
for(q=p->next; q; q=q->next)
{
if(q->data<p->data)
{
int t=p->data;
p->data=q->data;
q->data=t;
}
}
}
}
}
void create(int n,int m,int s)
{
for(int i=0; i<=n; i++)
{
head[i]=NULL;
}//创建一些头结点,因为是从头结点就开始存的数据,所以先全部初始化,之后构造边的时候,先判断头结点是不是空的,如果是空的,那就直接创建一个,然后往后面插点,不是空的,直接插点;
for(int i=1; i<=m; i++)
{
int u,v;
scanf("%d%d",&u,&v);
if(head[u]==NULL)//无向边,可能有点繁琐;
{
head[u]=new node;
head[u]->data=u;
head[u]->next=NULL;
struct node*p;
p=new node;
p->data=v;
p->next=head[u]->next;
head[u]->next=p;
}
else
{
struct node*p;
p=new node;
p->data=v;
p->next=head[u]->next;
head[u]->next=p;
}
if(head[v]==NULL)
{
head[v]=new node;
head[v]->data=v;
head[v]->next=NULL;
struct node*p;
p=new node;
p->data=u;
p->next=head[v]->next;
head[v]->next=p;
}
else
{
struct node*p;
p=new node;
p->data=u;
p->next=head[v]->next;
head[v]->next=p;
}
}
// for(int i=0;i<n;i++)
// {
// struct node*p;
// for(p=head[i];p;p=p->next)
// {
// printf("%d ",p->data);
// }
// printf("\n");
// }
arrange(n);
// for(int i=0;i<n;i++)
// {
// struct node*p;
// for(p=head[i];p;p=p->next)
// {
// printf("%d ",p->data);
// }
// printf("\n");
// }
queue<int>q;
memset(book,0,sizeof(book));
q.push(s);
book[s]=1;
int b[1001];
int w=0;
while(!q.empty())
{
int v=q.front();
b[w++]=v;//由于输出有空格的限制,所以先放到数组里面;
q.pop();
struct node*p;
p=head[v]->next;
while(p)
{
if(book[p->data]==0)//不能重复存边,不然就死循环了;
{
book[p->data]=1;
q.push(p->data);
}
p=p->next;
}
}
for(int i=0; i<w; i++)
{
if(i==0)printf("%d",b[i]);
else printf(" %d",b[i]);
}
printf("\n");
}
int main()
{
int t;
scanf("%d",&t);
while(t--)
{
int n,m,s;
scanf("%d%d%d",&n,&m,&s);
create(n,m,s);
}
return 0;
}