暑假算法心得------图的遍历BFS

1076 Forwards on Weibo (30)(30 分)提问

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID‘s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:

7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6

Sample Output:

4
5
#include <stdio.h>
#include <iostream>
#include <vector>
#include <queue>

using namespace std;

const int maxn=2000;
int N,L,M,userid;

vector<int> adj[maxn];
vector<int> res[maxn];
int layer[maxn];
int num[maxn]={0};
bool inq[maxn]={false};

void BFS(int u)
{
    int flag=0;
    queue<int> q;
    q.push(u);
    inq[u]=true;
    layer[u]=0;
    while(!q.empty())
    {
        int temp=q.front();//此处的temp不要写成u了
        q.pop();
        for(int v=0;v<adj[temp].size();v++)
        {
            if(inq[adj[temp][v]]==false)
            {
                q.push(adj[temp][v]);
                inq[adj[temp][v]]=true;
                layer[adj[temp][v]]=layer[temp]+1;
                if(layer[adj[temp][v]]>L)
                {
                    flag=1;
                    break;
                }
                else
                {
                    num[u]++; //根据题目条件,此处应该是将入队的点添加到起始点u的记录当中
                }

            }
        }
        if(flag) break;
    }

}

void BFSTraverse()
{
    int u,v;
    for(u=1;u<=N;u++)
    {
        if(inq[u]==false)
        {
            BFS(u);
        }
        for(v=1;v<=N;v++)
        {
            inq[v]=false; //根据题目条件,可知每次需要更新inq[v]的值
        }
    }
}

int main()
{
    cin>>N>>L;
    int i,j,k;
    for(i=1;i<=N;i++)
    {
        cin>>M;
        for(j=0;j<M;j++)
        {
            cin>>userid;
            adj[userid].push_back(i);
        }
    }
    BFSTraverse();
    cin>>M;
    for(i=0;i<M;i++)
    {
        cin>>N;
        cout<<num[N]<<endl;
    }
}

 

    原文作者:数据结构之图
    原文地址: https://blog.csdn.net/chengsilin666/article/details/81175494
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞