HDU1312
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
‘.’ – a black tile
‘#’ – a red tile
‘@’ – a man on a black tile(appears exactly once in a data set)
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9
….#.
…..#
……
……
……
……
……
@…
.#..#.
11 9
.#………
.#.#######.
.#.#…..#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#…….#.
.#########.
………..
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
.
…@…
.
..#.#..
.3
.#..
0 0
Sample Output
45
59
6
13
大意:就是让你以@为起点,只能走点,#不能走,最多能走到达多少个地方。
思路:bfs和dfs都可以做,下面用dfszuoyixia。
#include<stdio.h>
#include<string.h>
#define maxn 50
char str[maxn][maxn];
int cs[maxn][maxn];
int n,m,ans;
int d[4][2] = {1,0,-1,0,0,1,0,-1};
void dfs(int x,int y)
{
cs[x][y] = 1;
ans++;
for(int i = 0;i < 4; i++)
{
int dx = x + d[i][0];
int dy = y + d[i][1];
if(dx>=0 && dx<n && dy>=0 && dy<m && !cs[dx][dy] && str[dx][dy]!='#')
{
dfs(dx,dy);
}
}
}
int main()
{
while(scanf("%d%d",&m,&n)!=EOF && (n||m))
{
memset(cs,0,sizeof(cs));
for(int i = 0;i < n; i++)
scanf("%s",str[i]);
int xf,yf;
ans = 0;
for(int i = 0;i < n; i++)
for(int j = 0;j < m; j++)
{
if(str[i][j] == '@'){
xf = i,yf = j;
break;
}
}
dfs(xf,yf);
printf("%d\n",ans);
}
return 0;
}