PAT 甲级 1034 Head of a Gang(30 分)图的遍历,DFS

One way that the police finds the head of a gang is to check people’s phone calls. If there is a phone call between A and B, we say that A and B is related. The weight of a relation is defined to be the total time length of all the phone calls made between the two persons. A “Gang” is a cluster of more than 2 persons who are related to each other with total relation weight being greater than a given threthold K. In each gang, the one with maximum total weight is the head. Now given a list of phone calls, you are supposed to find the gangs and the heads.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive numbers N and K (both less than or equal to 1000), the number of phone calls and the weight threthold, respectively. Then N lines follow, each in the following format:

Name1 Name2 Time

where Name1 and Name2 are the names of people at the two ends of the call, and Time is the length of the call. A name is a string of three capital letters chosen from AZ. A time length is a positive integer which is no more than 1000 minutes.

Output Specification:

For each test case, first print in a line the total number of gangs. Then for each gang, print in a line the name of the head and the total number of the members. It is guaranteed that the head is unique for each gang. The output must be sorted according to the alphabetical order of the names of the heads.

Sample Input 1:

8 59
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 1:

2
AAA 3
GGG 3

Sample Input 2:

8 70
AAA BBB 10
BBB AAA 20
AAA CCC 40
DDD EEE 5
EEE DDD 70
FFF GGG 30
GGG HHH 20
HHH FFF 10

Sample Output 2:

0

题目大意:给出1000条以内的通话记录A B和权值w,和阈值k,如果一个团伙人数超过2人并且通话总权值超过k,令团伙里面的自身权值的最大值为头目,输出所有满足条件的团伙的头目,和他们团伙里面的人数
分析:总的来说是一个判断一个图的连通分量的个数,用图的遍历解决,深度优先遍历。
1.因为给的是字母,要用两个map把它们转换成数字,从0开始排列命名所有不同的人的id,存储在两个map里面,一个字符串对应id,一个id对应字符串,方便查找。
2.建立两个数组,t和weight,分别存储每条边的权值和每个结点的权值,因为这两个题目中都要求得后判断。
3.用传递引用的方法深度优先dfs,这样传入的参数在dfs后还能保存想要求得的值
4.遍历过一条边之后就把这条边的权值设为0( G[u][v] = G[v][u] = 0;)防止出现回路遍历死循环 

PS:有一个case一直找不通过找不到原因,后来发现是代码注释中的部分用vector去存储,而不是map去存储。。。

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;

const int N = 2002;
int n,k;

int edge[N][N],t[N][N],weight[N];
bool vst[N];

int max_weight = -999999,max_id = -1;

void dfs(int i,int &cnt,int &sum){
	cnt++;
	
	vst[i] = true;
	if(max_weight < weight[i]){
		max_weight = weight[i];
		max_id = i;
	}	
	
	for(int j=0;j<N;j++){
		if(t[i][j] > 0){
			sum += t[i][j];
			t[i][j] = t[j][i] = 0;//防止再次将该条权值和加上 
			if(edge[i][j]==1 && vst[j]==false){//只能访问一次每个点,因为cnt计数 
				dfs(j,cnt,sum);
			}	
		}	
	}					
}

int main(){
	fill(vst,vst+N,false);
	fill(weight,weight+N,0);
	
	int index = 0;
	cin>>n>>k;
	
	map<string,int> mp;
	map<int,string> int_map;
	for(int i=0;i<n;i++){
		string name1,name2;
		int a,b,c;
		cin>>name1>>name2>>c;
		
		auto it = mp.find(name1);
		if(it == mp.end())
			mp[name1] = index++;
			
		it = mp.find(name2);	
		if(it == mp.end())
			mp[name2] = index++;
			
		a = mp[name1],b = mp[name2];
		int_map[a] = name1,int_map[b] = name2;
		
		edge[a][b] = edge[b][a] = 1;
		t[a][b] += c;//这样可以计算出两点间所有边权之和 
		t[b][a] += c;
		weight[a] += c;
		weight[b] += c;
	}
	
	map<string,int> res;
	for(auto it:mp){
		int cnt = 0,sum = 0;
		max_weight = -999999,max_id = -1;
		if(!vst[it.second]){
			dfs(it.second,cnt,sum);
		}
		
		if(cnt > 2 && sum > k){
			res[int_map[max_id]] = cnt;//这里用map存储,如果用vector存储会有一个case不通过!! 				
		}	
	}
	
	cout<<res.size()<<endl;
	for(auto it:res)
		cout<<it.first<<" "<<it.second<<endl;	
	
	return 0;
}

解法二:

#include<iostream>
#include<map>
#include<vector>
#include<algorithm>
using namespace std;

const int N = 2002;
int n,k;

int edge[N][N],t[N][N],weight[N];
bool vst[N];

int max_weight = -999999,max_id = -1;

void dfs(int i,int &cnt,int &sum){
	cnt++;
	vst[i] = true;
	
	for(int j=0;j<N;j++){//计算所有边权值之和 
		if(edge[i][j] == 1)
			sum += t[i][j];
	}	
	
	if(max_weight < weight[i]){
		max_weight = weight[i];
		max_id = i;
	}	
	
	for(int j=0;j<N;j++)
		if(edge[i][j] == 1 && vst[j]==false){
			dfs(j,cnt,sum);
		}		
}

int main(){

	fill(vst,vst+N,false);
	fill(weight,weight+N,0);
	fill(t[0],t[0]+N*N,0);
	
	int index = 0;
	cin>>n>>k;
	
	map<string,int> mp;
	for(int i=0;i<n;i++){
		string name1,name2;
		int a;
		cin>>name1>>name2>>a;
		
		auto it = mp.find(name1);//注意:通过find才找才正确!!! 
		if(it == mp.end())
			mp[name1] = index++;
		
		it = mp.find(name2);	
		if(it == mp.end())
			mp[name2] = index++;
		
		edge[mp[name1]][mp[name2]] = edge[mp[name2]][mp[name1]] = 1;
		t[mp[name1]][mp[name2]] = a;
		weight[mp[name1]] += a;
		weight[mp[name2]] += a;
	}
	
	map<string,int> res;
	for(auto it:mp){
		int cnt = 0,sum = 0;
		max_weight = -999999,max_id = -1;

		if(!vst[it.second]){
			dfs(it.second,cnt,sum);
		}
		if(cnt > 2 && sum > k){
			for(auto it:mp)
				if(it.second == max_id){
					res[it.first] = cnt;//这里用map存储,如果用vector存储会有一个case不通过!! 
				}				
		}	
	}
	
	cout<<res.size()<<endl;
	for(auto it:res)
		cout<<it.first<<" "<<it.second<<endl;	
	
	return 0;
}

最后:附拿满分的链接:

    原文作者:数据结构之图
    原文地址: https://blog.csdn.net/qq_29762941/article/details/82227058
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞