数据结构实验之图论二:图的深度遍历
Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
请定一个无向图,顶点编号从0到n-1,用深度优先搜索(DFS),遍历并输出。遍历时,先遍历节点编号小的。
Input
输入第一行为整数n(0 < n < 100),表示数据的组数。 对于每组数据,第一行是两个整数k,m(0 < k < 100,0 < m < k*k),表示有m条边,k个顶点。 下面的m行,每行是空格隔开的两个整数u,v,表示一条连接u,v顶点的无向边。
Output
输出有n行,对应n组输出,每行为用空格隔开的k个整数,对应一组数据,表示DFS的遍历结果。
Sample Input
1 4 4 0 1 0 2 0 3 2 3
Sample Output
0 1 2 3
Hint
Source
dfs:相当于树的前序遍历,注意因为是无向图,所以要是双向的输入数组。
纯c代码如下:
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
int a[110][100];
int book[600];
int f, x;
int n, m;
void dfs(int x)
{
if(book[x] == 1) return ;
book[x] = 1;
if(f == 1)
{
printf(“%d”, x);
f = 0;
}
else
printf(” %d”, x);
int i;
for(i = 0; i < m; i++)
{
if(a[x][i] == 1)
dfs(i);
}
return;
}
int main()
{
int t;
scanf(“%d”, &t);
while(t–)
{
memset(book, 0, sizeof(book));
memset(a, 0, sizeof(a));
scanf(“%d%d”, &m, &n);
int q, p;
int i;
for(i = 0; i < n; i++)
{
scanf(“%d%d”, &q, &p);
a[q][p] = a[p][q] = 1;
}
f = 1;
dfs(0);
printf(“\n”);
}
return 0;
}