题目:
描述
图(graph)是数据结构 G=(V,E),其中V是G中结点的有限非空集合,结点的偶对称为边(edge);E是G中边的有限集合。设V={0,1,2,……,n-1},图中的结点又称为顶点(vertex),有向图(directed graph)指图中代表边的偶对是有序的,用<u,v>代表一条有向边(又称为弧),则u称为该边的始点(尾),v称为边的终点(头)。无向图(undirected graph)指图中代表边的偶对是无序的,在无向图中边(u,v )和(v,u)是同一条边。
输入边构成无向图,求以顶点0为起点的宽度优先遍历序列。
输入
第一行为两个整数n、e,表示图顶点数和边数。以下e行,每行两个整数,表示一条边的起点、终点,保证不重复、不失败。1≤n≤20,0≤e≤190
输出
前面n行输出无向图的邻接矩阵,最后一行输出以顶点0为起点的宽度优先遍历序列,对于任一起点,按终点序号从小到大的次序遍历每一条边。每个序号后输出一个空格。
样例输入
4 5
0 1
0 3
1 2
1 3
2 3
样例输出
0 1 0 1
1 0 1 1
0 1 0 1
1 1 1 0
0 1 3 2
代码:
#include <iostream>
#include <cstring>
#include <queue>
using namespace std;
class Graph
{
private:
int **a, n, e;//n点,e边
public:
Graph(int num, int edge);
~Graph();
void insert();//插入图的节点
bool exist(int u, int v);//是否存在(u,v)
void output();
void BFS();//深度优先
void BFS(int v, bool *used);
};
int main()
{
int n, m;//n点,m边
cin >> n >> m;
Graph graph(n, m);
graph.insert();
graph.output();
graph.BFS();
return 0;
}
Graph::Graph(int num, int edge)
{
n = num, e = edge;
a = new int*[n];
for(int i = 0; i < n; i++)
{
a[i] = new int[n];
memset(a[i], 0, n*sizeof(int));
}
}
Graph::~Graph()
{
for(int i = 0; i < n; i++)
{
delete []a[i];
}
delete []a;
}
void Graph::insert()
{
int na, nb;
for(int i = 0; i < e; i++)
{
cin >> na >> nb;
a[na][nb] = 1;
a[nb][na] = 1;
}
}
bool Graph::exist(int u, int v)
{
if(a[u][v]) return true;
return false;
}
void Graph::BFS()
{
bool *used = new bool[n];
int i;
for(i = 0; i < n; i++)
{
used[i] = false;
}
for(i = 0; i < n; i++)
{
if(!used[i])
{
BFS(i, used);
}
}
cout << endl;
delete []used;
}
void Graph::BFS(int v, bool *used)
{
queue<int> q;
cout << v << " ";
used[v] = true;
q.push(v);
while(!q.empty())
{
v = q.front();
q.pop();
for(int i = 0; i < n; i++)
{
if(!used[i] && a[v][i])
{
used[i] = true;
cout << i << " ";
q.push(i);
}
}
}
}
void Graph::output()
{
for(int i = 0; i < n; i++)
{
for(int j = 0; j < n; j++)
{
cout << a[i][j] << " ";
}
cout << endl;
}
}