[PAT甲级]1013. Battle Over Cities (25)(图的遍历,统计强连通分量个数)

1013. Battle Over Cities (25)

原题链接
It is vitally important to have all the cities connected by highways in a war. If a city is occupied by the enemy, all the highways from/toward that city are closed. We must know immediately if we need to repair any other highways to keep the rest of the cities connected. Given the map of cities which have all the remaining highways marked, you are supposed to tell the number of highways need to be repaired, quickly.

For example, if we have 3 cities and 2 highways connecting city1-city2 and city1-city3. Then if city1 is occupied by the enemy, we must have 1 highway repaired, that is the highway city2-city3.

Input

Each input file contains one test case. Each case starts with a line containing 3 numbers N (<1000), M and K, which are the total number of cities, the number of remaining highways, and the number of cities to be checked, respectively. Then M lines follow, each describes a highway by 2 integers, which are the numbers of the cities the highway connects. The cities are numbered from 1 to N. Finally there is a line containing K numbers, which represent the cities we concern.

Output

For each of the K cities, output in a line the number of highways need to be repaired if that city is lost.

Sample Input

3 2 3
1 2
1 3
1 2 3

Sample Output

1
0
0

题目大意:

  • 给出n个城市,城市间有m条路,k个要检查的城市
  • 假如这k个城市被攻占,所有相关的路线全部瘫痪,要使其他城市保持连通,至少需要修缮多少条路

    思路:

  • 其实这是考察图的问题,删除图的一个节点,是其他节点成为连通图,至少需要添加多少条线

  • 添加最少的路线,就是连通分量数-1(例:n个互相独立的连通分量组成一个连通图,只需要连n-1条线就可以)
  • 这道题最重要就是求除去图的一个节点后 剩余的连通分量的数目
  • 利用邻接矩阵v存储路线,用visit数组表示城市是否被遍历过
  • 对于每个被占领的城市,将其表示为遍历过的状态true即可
  • 利用深度优先遍历dfs计算连通分量数目

代码:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int v[1001][1001];//记录连通路线 默认为0 不连通
bool visit[1001];//记录是否遍历过
int n;//n个城市
void dfs(int node){
    visit[node] = true;
    for(int i=1; i<=n; i++){
        if(visit[i]==false && v[node][i] == 1){
            dfs(i);
        }
    }
}
int main()
{
    int m, k, a, b;//m条路 k个要检查的城市 ab为路线起点终点
    scanf("%d%d%d", &n, &m, &k);
    for(int i=0; i<m; i++){
        scanf("%d%d", &a, &b);
        v[a][b] = 1;
        v[b][a] = 1;
    }
    for(int i=0; i<k; i++){
        fill(visit, visit+1001, false);//重置visit 所有城市未被遍历
        int temp = 0;
        scanf("%d", &temp);
        visit[temp] = true;//被攻占的城市,标记为true
        int cnt = 0;//记录连通分量
        for(int j=1; j<=n; j++){
            if(visit[j] == false){
                dfs(j);
                cnt++;//连通分量+1
            }
        }
        printf("%d\n", cnt-1);//思路第二条
    }
    return 0;
}
    原文作者:数据结构之图
    原文地址: https://blog.csdn.net/whl_program/article/details/77627856
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞