SDUT-2107 图的深度遍历

图的深度遍历

Time Limit: 1000MS 
Memory Limit: 65536KB
Submit 
Statistic 
Discuss

Problem Description

请定一个无向图,顶点编号从0到n-1,用深度优先搜索(DFS),遍历并输出。遍历时,先遍历节点编号小的。

Input

输入第一行为整数n(0 < n < 100),表示数据的组数。 对于每组数据,第一行是两个整数k,m(0 < k < 100,0 < m < k*k),表示有m条边,k个顶点。 下面的m行,每行是空格隔开的两个整数u,v,表示一条连接u,v顶点的无向边。

Output

输出有n行,对应n组输出,每行为用空格隔开的k个整数,对应一组数据,表示DFS的遍历结果。

Example Input

1
4 4
0 1
0 2
0 3
2 3

Example Output

0 1 2 3

Hint

 

Author

 

#include <bits/stdc++.h>
using namespace std;
int Map[110][110],v[110],ans[110],num=0,k,m;
void DFS(int t)
{
    for(int i=0; i<k; i++)
    {
        if(Map[t][i]&&!v[i])
        {
            v[i]=1;
            ans[num++]=i;
            DFS(i);
        }
    }
}
int main()
{
    int n,x,y;
    scanf("%d",&n);
    while(n--)
    {
        num=0;
        scanf("%d%d",&k,&m);
        memset(v,0,sizeof(v));
        memset(Map,0,sizeof(Map));
        for(int i=0; i<m; i++)
        {
            scanf("%d%d",&x,&y);
            Map[x][y]=Map[y][x]=1;
        }
        ans[num++]=0;
        v[0]=1;
        DFS(0);
        for(int i=0; i<num; i++)
            printf("%d%c",ans[i],i==num-1?'\n':' ');
    }
    return 0;
}
    原文作者:数据结构之图
    原文地址: https://blog.csdn.net/wzy_2017/article/details/76577778
    本文转自网络文章,转载此文章仅为分享知识,如有侵权,请联系博主进行删除。
点赞